By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,542 Members | 1,097 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,542 IT Pros & Developers. It's quick & easy.

Java applets don't run in MS-IE 6 ?

P: n/a
I have a nice little applet on my web page at:

www.benslade.com/pictures/2003/jul/alaska/images/Ben's_Alaska_Vacation_Slideshow.html
(yes, that's an apostrophe in the URL, sorry)

It runs fine everywhere except for MS-IE 6.x browsers. There I just
get a grey screen where the applet is supposed to go. If I enable the
Java console log, I see a "ClassNotFound" exception coming from
Microsoft's Java VM (no explicit popup error message for this though)

I've noticed this problem on MS-IE 6.x on Windows 98 and XP
environments. I've turned the security down to "low" for Java applets
in these environments, but it doesn't help.

Once I load the Sun java plugin, things work fine.

What's going on here? Has Microsoft disabled java applets?

--
Ben in DC
Pu***********@benslade.com (put 030516 anywhere in the subj to get thru)
"It's the mark of an educated mind to be moved by statistics"
Oscar Wilde

Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Microsoft is limited to using version 1.1.6 of the Java VM (per the court
settlement between MS and Sun) in it's OS's and browsers. Your Sun Java
plugin is probably version 1.4.x and contains the classes that your applet
is referring to, so it works fine.

I'd put a link on your page for your users to DL'd and install the Sun
plugin with a note that your applet will not run of MS's old java VM.....

Larry

"Put 030516 in email subj to get thru" <Pu***********@benslade.com> wrote in
message news:R4*******************@nwrddc02.gnilink.net...
I have a nice little applet on my web page at:

www.benslade.com/pictures/2003/jul/alaska/images/Ben's_Alaska_Vacation_Slide
show.html (yes, that's an apostrophe in the URL, sorry)

It runs fine everywhere except for MS-IE 6.x browsers. There I just
get a grey screen where the applet is supposed to go. If I enable the
Java console log, I see a "ClassNotFound" exception coming from
Microsoft's Java VM (no explicit popup error message for this though)

I've noticed this problem on MS-IE 6.x on Windows 98 and XP
environments. I've turned the security down to "low" for Java applets
in these environments, but it doesn't help.

Once I load the Sun java plugin, things work fine.

What's going on here? Has Microsoft disabled java applets?

--
Ben in DC
Pu***********@benslade.com (put 030516 anywhere in the subj to get thru)
"It's the mark of an educated mind to be moved by statistics"
Oscar Wilde

Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.