By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,905 Members | 894 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,905 IT Pros & Developers. It's quick & easy.

SGI Java issue "Exception in thread "main" java.lang.UnsatisfiedLinkError: poll0"

P: n/a
Hello all;

I'm trying to debug an issue with a java script called, SelectSockets.
It appears to be a fairly common one found on the web. I downloaded
the SGI Java v1.4.1 installation from SGI's webpage and installed it
using SGI's swmgr application. The installation was very straight
forward and there were no errors when I installed the package.

Then I ran /usr/java2/bin/javac SelectSockets.java to make the
SelectSockets.class file.

Then I ran /usr/java2/bin/java SelectSockets, and got the following
error message:
================================================== ========
Listening on port 1234
Exception in thread "main" java.lang.UnsatisfiedLinkError: poll0
at sun.nio.ch.PollArrayWrapper.poll0(Native Method)
at sun.nio.ch.PollArrayWrapper.poll(PollArrayWrapper. java:100)
at sun.nio.ch.PollSelectorImpl.doSelect(PollSelectorI mpl.java:64)
at sun.nio.ch.SelectorImpl.select(SelectorImpl.java:6 2)
at SelectSockets.go(SelectSockets.java:62)
at SelectSockets.main(SelectSockets.java:29)
================================================== ==========

It appears to be a library error, but I'm not sure. I can run the
SelectSockets routine on a Solaris system without any issues.

Any help would be appreciated.

phil
Jul 17 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.