By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,296 Members | 1,469 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,296 IT Pros & Developers. It's quick & easy.

Error while running webservice in windows 2003 server

100+
P: 375
Hi,

I have a webservice, which works fine. I am working in windows xp. I hosted the webservice by integrating with .mpp file using COM component and it works successfully.

Now I uploaded into the server, its windows 2003 server. When I run the webservice it executes perfectly for the first time, whereas it does not execute from second time onwards. But the same webservice when worked from visual studio 2005 inside windows server 2003, runs successfully.

I get the error as below

System.Runtime.InteropServices.COMException: Call was rejected by callee. (Exception from HRESULT: 0x80010001 (RPC_E_CALL_REJECTED))
at System.RuntimeType.ForwardCallToInvokeMember(Strin g memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
at Microsoft.Office.Interop.MSProject.ApplicationClas s.Quit(PjSaveType SaveChanges)
at Service.CheckProject(String projectID) in C:\vcclient\App_Code\Service.vb:line 41

Line 41, consists of the following code

gobjProjectInstance1 = New Microsoft.Office.Interop.MSProject.Application

gobjProjectInstance.FileOpen(FileName)

But I repeat that it works fine while running in visual studio

Can anyone help me out please.

Regards

cmrhema
May 15 '09 #1
Share this Question
Share on Google+
2 Replies


100+
P: 375
Any one help please, this error is pulling my hair.
I am at my wits end
In case its not related to IIS, can the moderators please do me a favor, Can you please redirect it to the appropriate section.
I dont know whether it should be under .net because it deals with webservice, but again the problem was while hosting and running from there, so placed in IIS.
Kindly do the needful

Regards
cmrhema
May 18 '09 #2

Frinavale
Expert Mod 5K+
P: 9,731
It sounds like you have not given sufficient rights to the ASP.NET process identity so that it can access the MSProject COM component.
  • Run dcomcnfg to enter Component Services window.
  • Expand
    • -->Component Services
      • --> Computers
        • --> My Computer
          • --> DCOM Config
  • Right click Windows Management and Instrumentation, and click properties.
  • Select the Security tab, then select radio buttons which activate the Edit buttons in Access Permissions group.
  • Add the account.
  • Reboot.
May 20 '09 #3

Post your reply

Sign in to post your reply or Sign up for a free account.