470,591 Members | 1,498 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,591 developers. It's quick & easy.

PHP5 on IIS7 in Windows Server '08 - multiple site issues (sic)

scubak1w1
Hello,

I was/am using the excellent tutorial over at http://learn.iis.net/page.aspx/246/u...ons-on-iis-70/ to get PHP5.2.9 up and running on Server '08 and IIS7.

All was working well, got my site migrated across, code was working, data coming and going out of PostgreSQL in the back end, etc, etc...

So time to move another couple of sites to the install... and here is where I started to stumble - namely, IIS always 'calls' the PHP file in the first/original site's 'wwwroot' directory, even from other sites 'based' in other directories!? (assuming there is a PHP file there with the same name...)

That is, if you go to a PHP page on ANY of the sites with, say, the name 'test.php' the PHP page that is displayed is the 'test.php' site on the FIRST site created in the original 'wwwroot', not the 'test.php' in the directory for that site!!??

ASP, HTM, etc files are working as you would expect, that is calling them from the 'correct' site - and so I set the handler mapping for 'PHP via Fast CGI' to have the same Path Type as 'ASP', namely 'File', as a test - no luck...

I am thinking that 'PHP via Fast CGI' is somehow erroneously defaulting to the always 'calling' the PHP files of the same name in 'wwwroot'??

Any advice or suggestions would be GREATLY appreciated, 'cause I am stuck!

Note that I have just one php.ini file - but reading online I may need one for each site??

Note that I am a geologist who now does GIS, data management, web pages, etc for sharing scientific data... i.e., rather than a system admin; I am very happy to puzzle things out my self, but sometimes I of course get stuck like this due to my lack of specific knowledge! <smile>

Cheers: GREG...
Mar 13 '09 #1
1 2606
Found it!

I was using a php.ini file, a little adjusted, from the test server on IIS5.1 on an XP box, to help ensure I kept my settings as I had tweaked them...

In this 'carry over' php.ini file I had

Expand|Select|Wrap|Line Numbers
  1. ...
  2. doc_root = "C:\inetpub\wwwroot"
  3. ...
  4.  
I just REMed this out, rebooted the server (an IIS restart was not enough), viola!

Phew! I thought I was going nuts - and learnt to check my .ini file in great detail!

Cheers!
Mar 23 '09 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

6 posts views Thread by Spidah | last post: by
5 posts views Thread by =?Utf-8?B?bXVzb3NkZXY=?= | last post: by
6 posts views Thread by ma | last post: by
3 posts views Thread by =?Utf-8?B?T2xpdmllciBNQVRST1Q=?= | last post: by
12 posts views Thread by Alan M Dunsmuir | last post: by
2 posts views Thread by David Thielen | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.