469,903 Members | 1,519 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,903 developers. It's quick & easy.

Module_set_response_error_status

ram09
45
After deploying our site in the iis7 server, we encountered this error...

ModuleName AspNetInitializationExceptionModule
Notification 1
HttpStatus 500
HttpReason Internal Server Error
HttpSubStatus 0
ErrorCode 0
ConfigExceptionInfo
Notification BEGIN_REQUEST
ErrorCode The operation completed successfully. (0x0)

do anyone enountered this error message?? tnx
Jan 7 '09 #1
3 12670
ram09
45
I'm using a 3rd party component were in I need to register it's module. At first, I just added it's module on the web.server/module section of web.config of the application, but we had a problem with our deployed site. After reading some articles, I learned that I can add it's module on the MODULES section of the iis7 administrative tools. It is working but I found a problem because I needed to register it's module everytime I deploy a site, thinking that all our sites are using this module. So I searched and found out that I can add a module globally using the applicationhost.config.

So I added this in the <globalModules> section of application.config file:

<add name="Module Name" image"Module Location" />

then I also added something on the <modules> section

<add name="Module name" />


But after I added all this on our application.config file I cannot make our site run anymore it says SERVICE UNAVAILABLE...

I am thinking that I may have missed something in the way I registered the modules...

I also had a problem with the first procedure I did in adding a module on the administrative tools of the server because I encountered a problem also when I tried our deployed site because it has an error saying that the assembly of the module was not registered on the web.config..
But I already checked the web.config of our application and it already registered the assembly on the <assemblies> section..

<add assembly="Module Name, Version=1.3.0.0, Culture=neutral, PublicKeyToken=0f5ecb088372736c" />

doed anyone encountered this problem? I am only new with iis7 and I might be missing some things..
Jan 9 '09 #2
Frinavale
9,735 Expert Mod 8TB
Is your third party component properly installed onto the server when you deploy your application?

I tried searching for: AspNetInitializationExceptionModule but discovered that this doesn't exist. What is the exact exception you are getting?
Jan 20 '09 #3
ram09
45
thank you for the reply, we just found out that we had some problems with iis7 regarding some security issues, that's why the server cannot find the module...
we think that this is also our fault because we develop the site locally.. we are only new with web development, And after encountering this problems, we decided to develop in the iis7 environment, so that we won't have some problems when it comes to deployment... thanks again for the reply... ^_^
Jan 21 '09 #4

Post your reply

Sign in to post your reply or Sign up for a free account.

By using this site, you agree to our Privacy Policy and Terms of Use.