By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,825 Members | 1,242 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,825 IT Pros & Developers. It's quick & easy.

'Error Code 64: Host not available' - error when trying to access website

P: 1
There is a problem with accessing an ASP appln hosted on a dedicated Win '03 load balanced server running IIS 6.0 in worker process isolation mode.
When the user types in the URl of the appln and hits enter, some times they get a 'Page Cannot be Displayed' error. The details of the error are:
-----------------------------------------------------
> The page cannot be displayed
> Explanation: The Web server connection was closed.

> Technical Information (for support personnel)
> * Error Code 64: Host not available
> * Background: The connection to the Web server was lost.
--------------------------------------------------------
When this error happens only restarting the IIS admin services helps. The site then works for a while before it gives the above mentioned error again. This error happens randomly and cannot be simulated on demand. In the DEV server (not load balanced) the error doesn't occur at all. In the Test server this error occurs very often and in the PROD server its's about 1-2 a month. Except for the developmnet server the rest are load balanced.

When the error occured I checked on the IIS Admin services, the appln logs and the IIS logs. The IIS services are running fine, the appln pool shows as running and the w3wp worker process is visible in the task mon. The appln error logs don not show anything wrong. The http error logs too don't show anything when this error occurs. The only error logged there were some 'Connection Abandoned by Appln Pool' errors, but this was not just before the error occured.

Initially I had thought that it was because of a known memory leak in the appln combined with bad code that was causing the IIS to run out of memory. So I cleaned up the code - released all DB objs by Set conn = Nothing, and set the worker process to recycle every day-yet no effect. Is this an IIS server issue? Or is it an environment issue? If not then what else could be the probable causes? A proxy server/firewall to be blamed here?

Pls help!!!
Aug 10 '07 #1
Share this Question
Share on Google+
2 Replies


kenobewan
Expert 2.5K+
P: 4,871
Are there any differences in the platform of the servers & settings in IIS?
Although it sounds like a performance issue - any services are lost when the connection is lost? You are more likely to solve the issue on the test as it happens more often - you need a more reliable error or a way to trap it.
Aug 10 '07 #2

P: 1
I have a similar problem.

I am having "Apache/2.2.3 (Win32) mod_ssl/2.2.3 OpenSSL/0.9.8d mod_perl/2.0.3-dev Perl/v5.8.8" as a web server, with PHP and MySql , on a windows 2003 SP2 server.

The problem is that during some period Apache hangs permanently and it
runs fine only on restarting Apache. Browser (IE) simply hangs at that time and continously keeps on rotating and ultimately after a long search it gives
the "page cannot be displayed" error.I can't figure out which particular
activity is making Apache to hang.
This happens usually 2 to 3 times everyday. But sometimes entire day passes
without this also.
This problem is pending for the last 3 weeks. I studied several apache logs but could not sort out anything from that.

This problem became very critical because we have published several site in the this web server.

when i try to monitor with a site online a get this msg:

Error Code 64: Host not available
Background: The connection to the Web server was lost.

If someone could help me i appreciate.

Regards,
Sep 3 '09 #3

Post your reply

Sign in to post your reply or Sign up for a free account.