470,624 Members | 2,538 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,624 developers. It's quick & easy.

IIS 500-100 Custom Error - irreversible setting?

4
Hi all!


Brief subject:

I have to develop an ASP-based application, and build also a specific error handling ASP. After that I had set the virtual directory Custom Error 500;100 to new ASP - and now I have no error handling at all. Even if I reset it to Default!


Detailed description:

First I developed the error handling code directly in 500-100.asp, making no setting to IIS (under localhost). It worked fine, both all the standard functionality of 500-100.asp and the new-written messaging that sends e-mail to me (containing asp error details).
  • After all the successful testing the 500-100.asp had been restored
  • The new 500-100_company.asp had been placed in wwwroot dir.
  • In the IIS Mamager /(virtual directory) /Properties /Custom Errors tab /500;100 was set to URL, pointing onto /500-100_company.asp

The workflow descripted above seems to ruin totally the error handling of IIS. I am unable to reset even the original 500-100 error handling functionality (setting in manager to Default or any other way). The new error handling ASP cannot be set to work as well.

The effect is the same both on IIS 5.1, or 6.0

What's wrong, who could help me?
András
Jan 16 '07 #1
5 7019
radcaesar
759 Expert 512MB
Check ur ie settings

Tools | Internet Options | Advanced --> Show friendly HTTP error messages

u have to uncheck this one to show custom errors.

:)


Hi all!


Brief subject:

I have to develop an ASP-based application, and build also a specific error handling ASP. After that I had set the virtual directory Custom Error 500;100 to new ASP - and now I have no error handling at all. Even if I reset it to Default!


Detailed description:

First I developed the error handling code directly in 500-100.asp, making no setting to IIS (under localhost). It worked fine, both all the standard functionality of 500-100.asp and the new-written messaging that sends e-mail to me (containing asp error details).
  • After all the successful testing the 500-100.asp had been restored
  • The new 500-100_company.asp had been placed in wwwroot dir.
  • In the IIS Mamager /(virtual directory) /Properties /Custom Errors tab /500;100 was set to URL, pointing onto /500-100_company.asp

The workflow descripted above seems to ruin totally the error handling of IIS. I am unable to reset even the original 500-100 error handling functionality (setting in manager to Default or any other way). The new error handling ASP cannot be set to work as well.

The effect is the same both on IIS 5.1, or 6.0

What's wrong, who could help me?
András
Jan 17 '07 #2
jegec
4
Thanks, Radcaesar...

'Course I will try, but...
  1. If it is so, why do not work the 'Default' (re)setting for 500-100?
  2. My browser in which I have tested is a Mozilla Firefox 2.0

Do you have some suggestions?
Jegec

P.S.: As I wrote before, the effect is the same on IIS 5.x and 6.0. Alas, I've got in trouble not only on my own machine but also on two remote servers :-( and it urges me to solve the problem quite rapidly...
Jan 17 '07 #3
jegec
4
I unchecked the "Show friendly..." option and experienced no change. Still the appearing error page looks exactly as shown below (just not in bold) both in IE and Firefox:

Microsoft VBScript runtime error '800a01f4'

Variable is undefined: 'blabla'

/donpepe/RendFelv/src/DonPepe_RendFelv_Main.asp, line 5
Jan 17 '07 #4
radcaesar
759 Expert 512MB
Be sure that u did the following,

1. Create a file that contains your custom error message, and place it in a directory.

2. In the Internet Information Services snap-in, select the Web site, virtual directory, directory, or file you would like to customize HTTP errors, and then click Properties.

3. Select Custom Errors.

4. Select the HTTP error that you would like to change, in this case 404.

5. Click Edit Properties.

6. Select File from the drop-down list.

7.Enter the full path that points to your customized error message, or use Browse... to locate the file on your computer's hard disk.

8. Click OK.

:)
Jan 17 '07 #5
jegec
4
Hi, rad!

Sure I did the very things you have suggested, with only 3 points to discuss (may be, both have no relation to the core problem, but who knows...):
  1. the error to be customized is the 500;100 (Internal Server ASP) and not the 404 error;
  2. therefore its pointer will be of type URL or Default, not File as for html-s;
  3. what is the snap-in in practice (could I make these same settings elsewhere)?

Have a nice week-end!
András
Jan 19 '07 #6

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

79 posts views Thread by Tim Tyler | last post: by
reply views Thread by Evan Escently | last post: by
9 posts views Thread by John | last post: by
4 posts views Thread by Alex Vinokur | last post: by
3 posts views Thread by barhoooooom | last post: by
4 posts views Thread by Dean R. Henderson | last post: by
2 posts views Thread by Siva | last post: by
reply views Thread by mcfly1204 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.