468,107 Members | 1,315 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,107 developers. It's quick & easy.

a:hover in Firefox VS MSIE

Hi,

I got a problem with MSIE, using the below CSS... MSIE won't obey my
sheet, whereas Firefox does it exactly right. Anyone knows an
solution/explanation..?

..border1 {
border: thin solid #990000;
}
a:link {
color: #000000;
text-decoration: none;
}
a:hover {
color: #FFFFFF;
background-color: #990000;
}
a:active {
color: #FFFFFF;
text-decoration: none;
}
a:visited {
color: #000000;
text-decoration: none;
}
..tekstbrood {
font-family: Georgia, "Times New Roman", Times, serif;
font-size: 14px;
text-decoration: none;
}
Jul 20 '05 #1
3 5997
Els
Frederik wrote:
Hi,

I got a problem with MSIE, using the below CSS... MSIE
won't obey my sheet, whereas Firefox does it exactly right.
Anyone knows an solution/explanation..?

.border1 {
border: thin solid #990000;
}
a:link {
color: #000000;
text-decoration: none;
}
a:hover {
color: #FFFFFF;
background-color: #990000;
}
a:active {
color: #FFFFFF;
text-decoration: none;
}
a:visited {
color: #000000;
text-decoration: none;
}
.tekstbrood {
font-family: Georgia, "Times New Roman", Times, serif;
font-size: 14px;
text-decoration: none;
}


What if you get the order right, like this:

a:link
a:visited
a:hover
a:active

In the order you used, hover wouldn't work on visited links.

--
Els
http://locusmeus.com/
Sonhos vem. Sonhos vo. O resto imperfeito.
- Renato Russo -
Jul 20 '05 #2
Frederik skrev:
I got a problem with MSIE, using the below CSS... MSIE won't obey my
sheet, whereas Firefox does it exactly right. Anyone knows an
solution/explanation..?


It's wrong order, it must be

link
visited
hover
active
--
Knud
Topposter du svar, s ryger du p min ignoreringsliste.
http://usenet.dk/netikette/citatteknik.html
Jul 20 '05 #3
Knud Gert Ellentoft <el*******@mail.tele.invalid> wrote in message news:<as********************************@dtext.new s.tele.dk>...
Frederik skrev:
I got a problem with MSIE, using the below CSS... MSIE won't obey my
sheet, whereas Firefox does it exactly right. Anyone knows an
solution/explanation..?


It's wrong order, it must be

link
visited
hover
active


Thanks Els, thanks Knud..! It's working perfectly now.
Jul 20 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by Alan J. Flavell | last post: by
17 posts views Thread by harshpatel | last post: by
2 posts views Thread by Kevin Smith | last post: by
5 posts views Thread by Gerry Vandermaesen | last post: by
11 posts views Thread by zzpat | last post: by
1 post views Thread by Solo | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.