By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,447 Members | 1,172 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,447 IT Pros & Developers. It's quick & easy.

Forcing URL display on A:HOVER

P: n/a
(Cross-posted because I use Mozilla Firefox, but I think it's also
CSS issue.)

Usually when I move mouse over a link, the URL is displayed at the
bottom on "status line". On some website, however, this is surpressed.
This is very annoying, because I can't find out the destination URL
unless I click it. When I click it, the URL shows up as soon as mouse
button is pressed. So, this is A:HOVER and A:ACTIVE related.

At the moment, my ~/.phoenix/default/hm1kx1pj.slt/chrome/userContent.css
contains,
a:link { text-decoration:underline !important; }
a:visited { text-decoration:underline !important; }
a:hover { text-decoration:underline !important; }
to force underlining of all links. But, showing URL on browser's status
line is more of browser idiosyncracy than CSS thing.

How do you force Mozilla Firefox to display URL link on bottom status
line?

--
William Park, Open Geometry Consulting, <op**********@yahoo.ca>
Linux solution/training/migration, Thin-client
Jul 20 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
William Park <op**********@yahoo.ca> wrote:
(Cross-posted because I use Mozilla Firefox, but I think it's also
CSS issue.)
I think it's neither a Mozilla issue nor a CSS issue. (It's typical that
when a message is crossposted or multiposted, it actually does not
actually belong to _any_ of the groups it was posted to.)
Usually when I move mouse over a link, the URL is displayed at the
bottom on "status line". On some website, however, this is surpressed.


You would first need to post sample URL(s) to and identify which link(s)
on specific pages you mean. And you need to decide whether this a browser
usage question or an authoring question, and select the group
accordingly. _Probably_ the problematic page(s) use JavaScript and set
window.status='', and you would then need to ask how to switch scripting
off on your browser and what that would imply.

--
Yucca, http://www.cs.tut.fi/~jkorpela/
Jul 20 '05 #2

P: n/a
["Followup-To:" header set to netscape.public.mozilla.general.]

On 2004-05-08, Jukka K. Korpela <jk******@cs.tut.fi> wrote:
William Park <op**********@yahoo.ca> wrote:
(Cross-posted because I use Mozilla Firefox, but I think it's also
CSS issue.)


I think it's neither a Mozilla issue nor a CSS issue. (It's typical that
when a message is crossposted or multiposted, it actually does not
actually belong to _any_ of the groups it was posted to.)


Indeed. I'm setting followups to n.p.mozilla.general, as that tends to be
used for Mozilla support questions, even though that wasn't it's original
purpose. The best place for Firefox questions is the web forum -
http://forums.mozillazine.org/viewforum.php?f=38 . There's also the
newsgroups on the private server which are listed at
http://www.ufaq.org/modules.php?name...ticle&artid=21
Usually when I move mouse over a link, the URL is displayed at the
bottom on "status line". On some website, however, this is surpressed.


_Probably_ the problematic page(s) use JavaScript and set
window.status='', and you would then need to ask how to switch scripting
off on your browser and what that would imply.


You don't actually need to switch scripting off altogether to achieve that
in Firefox.

If you go to Tools | Options and then "Web features". You can disable
script by unchecking the "enable Javascript" box, but that will break a
lot of sites.

Next to the "enable Javascript" setting there is an "advanced" button.
Clicking that will give you a box with "allow scripts to" options,
including "change status bar text", unchecking that will prevent sites
changing the status bar text to suppress the URL. You might also want to
turn off the ability for sites to hide the status bar.

--
Michael
Jul 20 '05 #3

P: n/a
In <comp.infosystems.www.authoring.stylesheets> Michael Lefevre
<ne************@michaellefevre.com> wrote:
If you go to Tools | Options and then "Web features". You can disable
script by unchecking the "enable Javascript" box, but that will break
a lot of sites.

Next to the "enable Javascript" setting there is an "advanced" button.
Clicking that will give you a box with "allow scripts to" options,
including "change status bar text", unchecking that will prevent sites
changing the status bar text to suppress the URL. You might also want
to turn off the ability for sites to hide the status bar.


I have Java and Javascript off all the time. An example is
<www.microsoft.com> where
Microsoft.com Home | MSN Home | Subscribe | Manage Your Profile
does not show its URL when mouse moves over the four links. All others
links do show up.

Probably, Firefox issue. Sorry for noise in
<comp.infosystems.www.authoring.stylesheets> group.

--
William Park, Open Geometry Consulting, <op**********@yahoo.ca>
Linux solution/training/migration, Thin-client
Jul 20 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.