467,874 Members | 1,730 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,874 developers. It's quick & easy.

link tag refusing to validate...

http://validator.w3.org/ keeps coming back with
"Line 4, column 93: end tag for "link" omitted, but OMITTAG NO was
specified

....stylesheet" id="css" type="text/css">

You may have neglected to close a tag, or perhaps you meant to "self-
close" a tag; that is, ending it with "/>" instead of ">". "

for the following

<link href="styles/cn_styles.css" rel="stylesheet" id="css"
type="text/css"/>

it should be fine under xhtml 1, afaiks.....
The full markup of the header is

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<title>CouncilNet home</title>
<link href="styles/cn_styles.css" rel="stylesheet" id="css"
type="text/css"/>
<script language="javascript" src="/inc/js_popup_window.js"
type="text/javascript"></script>
<script type="text/javascript" src="/inc/js_colours.js"
language="javascript" ></script>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-
1" />
Jul 20 '05 #1
  • viewed: 1020
Share:

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by stanio | last post: by
4 posts views Thread by ben.dixon | last post: by
reply views Thread by jack112 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.