By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,628 Members | 1,401 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,628 IT Pros & Developers. It's quick & easy.

using basic authtype hides directory??

P: n/a
i have a catch-all directory that i want my users to be able to
access. (the stuff changes frequently enough that i don't want to
spend time maintaining an index.html.) i have the indexes option
enabled in the server. this all works fine: e.g.
http://www.4mla1fn.com

now, i have one directory in that list that i want to protect with
authtype basic. however when i do this, the directory name vanishs
from the directory listing. e.g. if i create a directory called
"restricted" and setup authtype (via .htaccess and .htpasswd) for that
directory, then "restricted " will not appear in the directory
listing.

is there a way around this?? thanks alot.
Jul 20 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
"4MLA1FN" ...
i have a catch-all directory that i want my users to be able to
access. (the stuff changes frequently enough that i don't want to
spend time maintaining an index.html.) i have the indexes option
enabled in the server. this all works fine: e.g.
http://www.4mla1fn.com

now, i have one directory in that list that i want to protect with
authtype basic. however when i do this, the directory name vanishs
from the directory listing. e.g. if i create a directory called
"restricted" and setup authtype (via .htaccess and .htpasswd) for that
directory, then "restricted " will not appear in the directory
listing.


I assume you have removed the restrictions
on 'restricted' 'coz I can see it from here..

One thought, you put an authtype on it,
it disappears. What happens if you browse
to the directory then add 'restricted/ to the
address in the menu bar and press 'enter'..

It should take you to the directory, even
if only to present the log-in, no?

--
Andrew Thompson
* http://www.PhySci.org/ Open-source software suite
* http://www.PhySci.org/codes/ Web & IT Help
* http://www.1point1C.org/ Science & Technology
Jul 20 '05 #2

P: n/a
On Wed, 25 Feb 2004 21:12:09 GMT, "Andrew Thompson"
<Se********@www.invalid> wrote:
I assume you have removed the restrictions
on 'restricted' 'coz I can see it from here..
yep.
What happens if you browse
to the directory then add 'restricted/ to the
address in the menu bar and press 'enter'..


the authentication dialog appear. (this is equivalent to clicking a
link to the files in the directory; problem is i'd rather not make a
webpage for directory.)
Jul 20 '05 #3

P: n/a
4MLA1FN wrote:
now, i have one directory in that list that i want to protect with
authtype basic. however when i do this, the directory name vanishs
from the directory listing. e.g. if i create a directory called
"restricted" and setup authtype (via .htaccess and .htpasswd) for that
directory, then "restricted " will not appear in the directory
listing.

is there a way around this?? thanks alot.


You could use Apache's HeaderName or ReadmeName directives to provide a
custom header or footer for the index, and put a link to the protected
directory in that.

sherm--
Jul 20 '05 #4

P: n/a
On Wed, 25 Feb 2004 14:51:56 -0500, 4MLA1FN
<rchong@-----speakeasy.net> wrote:
however when i do this, the directory name vanishes...


interesting. i just changed webservers (from 2.0.40 to 1.3.29) and now
it works. now, the index shows the protected directory. when
clicked, i authenticate, then get to see the contents. very cool.
e.g.:

go to http://www.4mla1fn.com/sti/ and click on "sti-manual".
Jul 20 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.