By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,573 Members | 903 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,573 IT Pros & Developers. It's quick & easy.

<link> - "rel='shortcut icon'" Not Working with HTTPS???

P: n/a
I'm encountering some wierd behavior with a <link> tag over an HTTPS
connection, vs. an HTTP connection...

In an ASP/HTML page on my website, I've add a <link rel="shortcut
icon"...> in order to allow the users to add a shortcut (with icon) on
their desktop, as well as seeing the icon in the URL. Our development
server allows both HTTP and HTTPS connections, but the icon only
appears to be available when requesting the page via HTTP???

When I hit the page from a browser as http://myweb/mypage.asp, I can
send a shortcut to my desktop and the Icon is associated with that
shortcut as well as the URL in the address bar showing the Icon, much
like a yahoo icon in the URL.

When I hit the page from a browser as https://myweb/mypage.asp, and
send the shortcut to the desktop, I get a default IE Icon and same
goes for the URL... When I do a "view source", the <link> line is
present, so I'm at a loss as to why it is not working

Any help would be greatly appreciated! Below is an example of the
code in the page:

<HTML>
<HEAD>
<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">
<link rel="shortcut icon" href="myLogo.ico" type="image/x-icon">
</HEAD>
<BODY>

<P>&nbsp;</P>

</BODY>
</HTML>
Jul 20 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Todd Peterson wrote:
I'm encountering some wierd behavior with a <link> tag over an HTTPS
connection, vs. an HTTP connection...

<link rel="shortcut icon" href="myLogo.ico" type="image/x-icon">


<link rel="shortcut icon" href="http://www.example.com/myLogo.ico"
type="image/x-icon"> should work

--
Klaus Johannes Rusch
Kl********@atmedia.net
http://www.atmedia.net/KlausRusch/
Jul 20 '05 #2

P: n/a
Thanks guys! I appreciate the responses!

Best Regards,
Todd
"D. Stussy" <kd****@bde-arc.ampr.org> wrote in message news:<Pi*****************************@kd6lvw.ampr. org>...
On Thu, 14 Aug 2003, Klaus Johannes Rusch wrote:
Todd Peterson wrote:
I'm encountering some wierd behavior with a <link> tag over an HTTPS
connection, vs. an HTTP connection...

<link rel="shortcut icon" href="myLogo.ico" type="image/x-icon">


<link rel="shortcut icon" href="http://www.example.com/myLogo.ico"
type="image/x-icon"> should work


Also note that for some web servers, HTTP and HTTPS protocols for fetching
things have different document roots. You may have to duplicate your icons
into the HTTPS document root (if you don't want to do the above).

Jul 20 '05 #3

P: n/a
Ok... so I was able to give the recommendation a shot and for some
reason, it still isn't working???

We are running IIS and as far as I know, there is only one document
root "inetpub\wwwroot\myapp". I was preferring not to use the
absolute path, "http://myserver...", in the link reference as the URL
is different for our development, test and production environments.
In the interest of just getting it to work, I coded in the absolute
path to my production server and made sure to put the .ico file in an
"images" directory so that it would work for dev, test and prod, only
pointing to the production file for each instance. i.e.
"http://ProductionServer/MyApp/images/myIcon.ico"

<I hope I haven't completely caused eyes to glaze over> ;-)

Again, to my dismay... the icon was picked up when accessing the page
via HTTP and missing when accessing via HTTPS?

Is there something else I'm missing? I'm truly perplexed that upon
doing a "view source" of the HTTPS page, I see the <link> with the
appropriate location yet it doesn't seem to get delivered to the
browser

Thanks again for any suggestions!

Best Regards,
Todd

"D. Stussy" <kd****@bde-arc.ampr.org> wrote in message news:<Pi*****************************@kd6lvw.ampr. org>...
On Thu, 14 Aug 2003, Klaus Johannes Rusch wrote:
Todd Peterson wrote:
I'm encountering some wierd behavior with a <link> tag over an HTTPS
connection, vs. an HTTP connection...

<link rel="shortcut icon" href="myLogo.ico" type="image/x-icon">


<link rel="shortcut icon" href="http://www.example.com/myLogo.ico"
type="image/x-icon"> should work


Also note that for some web servers, HTTP and HTTPS protocols for fetching
things have different document roots. You may have to duplicate your icons
into the HTTPS document root (if you don't want to do the above).

Jul 20 '05 #4

P: n/a
Todd Peterson wrote:
Is there something else I'm missing? I'm truly perplexed that upon
doing a "view source" of the HTTPS page, I see the <link> with the
appropriate location yet it doesn't seem to get delivered to the
browser


It might be helpful to supply an actual URL so people can try to debug it.

--
== Dan ==
Dan's Mail Format Site: http://mailformat.dan.info/
Dan's Web Tips: http://webtips.dan.info/
Dan's Domain Site: http://domains.dan.info/

Jul 20 '05 #5

P: n/a
Tim
On 15 Aug 2003 15:49:31 -0700,
to***********@billing.com (Todd Peterson) wrote:
We are running IIS and as far as I know, there is only one document
root "inetpub\wwwroot\myapp". I was preferring not to use the
absolute path, "http://myserver...", in the link reference as the URL
is different for our development, test and production environments.
In the interest of just getting it to work, I coded in the absolute
path to my production server and made sure to put the .ico file in an
"images" directory so that it would work for dev, test and prod, only
pointing to the production file for each instance. i.e.
"http://ProductionServer/MyApp/images/myIcon.ico"

<I hope I haven't completely caused eyes to glaze over> ;-)

Again, to my dismay... the icon was picked up when accessing the page
via HTTP and missing when accessing via HTTPS?


On different browsers? It couldn't just be a case of browser
configuration to ignore mixed content (secure/non-secure) on a page?

Note that what you're doing is bad news, for that reason. It'll throw
up security warnings at people.

--
My "from" address is totally fake. (Hint: If I wanted e-mails from
complete strangers, I'd have put a real one, there.) Reply to usenet
postings in the same place as you read the message you're replying to.
Jul 20 '05 #6

P: n/a
Thanks again to all for the responses! I had a co-worker access the
page from his browser and voila... Apparently, it is a browser
security setting! Now... to find out which one... ;-)

I sincerely appreciate everyone taking the time to respond, ultimately
leading me to identification of the problem!!!

Best Regards,
Todd

Tim <ad***@sheerhell.lan> wrote in message news:<62********************************@4ax.com>. ..
On 15 Aug 2003 15:49:31 -0700,
to***********@billing.com (Todd Peterson) wrote:
We are running IIS and as far as I know, there is only one document
root "inetpub\wwwroot\myapp". I was preferring not to use the
absolute path, "http://myserver...", in the link reference as the URL
is different for our development, test and production environments.
In the interest of just getting it to work, I coded in the absolute
path to my production server and made sure to put the .ico file in an
"images" directory so that it would work for dev, test and prod, only
pointing to the production file for each instance. i.e.
"http://ProductionServer/MyApp/images/myIcon.ico"

<I hope I haven't completely caused eyes to glaze over> ;-)

Again, to my dismay... the icon was picked up when accessing the page
via HTTP and missing when accessing via HTTPS?


On different browsers? It couldn't just be a case of browser
configuration to ignore mixed content (secure/non-secure) on a page?

Note that what you're doing is bad news, for that reason. It'll throw
up security warnings at people.

Jul 20 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.