By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
462,143 Members | 744 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 462,143 IT Pros & Developers. It's quick & easy.

Rollover Button Not Working In Firefox

P: 3
Hi all - I've managed to get 3 out of 4 of my rollover buttons to work in Firefox but my 4th one (Forms) doesn't want to cooperate. Can anyone help? It seems to work fine in other browsers...strange. Here is the link - keep in mind this is a work in progress ;)
http://chicagostrivingreaders.org/rresidori/public_html/rresidori/
May 23 '10 #1
Share this Question
Share on Google+
4 Replies

drhowarddrfine
Expert 5K+
P: 7,435
I'm sitting in a hotel in Chicago as I write this, heh.

The javascript for that image swap is not the same as the other buttons. So, for whatever reason, FF is not being served the same as the others cause the js is not the same in Chrome, for example.
May 24 '10 #2

P: 3
@drhowarddrfine
Nice weather today huh?
Quick question then, I use Dreamweaver and it automatically generates this code per image. Do you happen to know what exactly I need to change? I don't know how you read that code and figured that out so quickly!
May 24 '10 #3

drhowarddrfine
Expert 5K+
P: 7,435
@rresidori
I don't use DW. The way you look at the markup is through "view source" or a debugger built into the browser or the very excellent Firefox add-on "Firebug".
May 24 '10 #4

P: 3
So, I finally figured out the problem and figured I should post the solution here...I was using a button that I created for a section called 'Forms.' The problem was that I called the button 'Forms' as well. It turns out, that in Firefox, it was treating this button as some type of actual form rather than a button. Strange behavior but when I renamed me button, it worked!!

Cheers!
Jun 2 '10 #5

Post your reply

Sign in to post your reply or Sign up for a free account.