471,583 Members | 1,515 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,583 software developers and data experts.

Textarea style not applied on first load

I have a textarea that is styled by the following.

textarea
{
width: 100%;
line-height: 13pt;
font-family: Arial, Verdana, Helvetica;
text-align: left;
overflow: auto;
}

When I first load the page containing this element, it is unstyled
(default appearance). However, the styling of all the other elements
are fine (same stylesheet). When I refresh the page, the style is
applied as expected! Any ideas?
Nov 22 '07 #1
3 3456
On Thu, 22 Nov 2007 22:29:02 +0100, ShaggyMoose <sh*********@gmail.com>
wrote:
I have a textarea that is styled by the following.

textarea
{
width: 100%;
line-height: 13pt;
font-family: Arial, Verdana, Helvetica;
text-align: left;
overflow: auto;
}

When I first load the page containing this element, it is unstyled
(default appearance). However, the styling of all the other elements
are fine (same stylesheet). When I refresh the page, the style is
applied as expected! Any ideas?
URL? I'd like to see this in practise...
--
Rik Wasmus
Nov 22 '07 #2
On Nov 22, 7:57 pm, "Rik Wasmus" <luiheidsgoe...@hotmail.comwrote:
On Thu, 22 Nov 2007 22:29:02 +0100, ShaggyMoose <shaggymo...@gmail.com>
wrote:
I have a textarea that is styled by the following.
textarea
{
width: 100%;
line-height: 13pt;
font-family: Arial, Verdana, Helvetica;
text-align: left;
overflow: auto;
}
When I first load the page containing this element, it is unstyled
(default appearance). However, the styling of all the other elements
are fine (same stylesheet). When I refresh the page, the style is
applied as expected! Any ideas?

URL? I'd like to see this in practise...
--
Rik Wasmus
Unfortunately, its an internal website that I can't host externally.
As a workaround, I am re-applying the style in Javascript onload. Not
pretty, but it works.
Nov 23 '07 #3
On Fri, 23 Nov 2007 13:26:04 +0100, ShaggyMoose <sh*********@gmail.com>
wrote:
On Nov 22, 7:57 pm, "Rik Wasmus" <luiheidsgoe...@hotmail.comwrote:
>On Thu, 22 Nov 2007 22:29:02 +0100, ShaggyMoose <shaggymo...@gmail.com>
wrote:
I have a textarea that is styled by the following.
textarea
{
width: 100%;
line-height: 13pt;
font-family: Arial, Verdana, Helvetica;
text-align: left;
overflow: auto;
}
When I first load the page containing this element, it is unstyled
(default appearance). However, the styling of all the other elements
are fine (same stylesheet). When I refresh the page, the style is
applied as expected! Any ideas?

URL? I'd like to see this in practise...

Unfortunately, its an internal website that I can't host externally.
I find it hard to believe you cannot save the source (possibly trim it
down/remove sensitive content) plus possible css & images, and put it on
one of the thousands of free servers out there.
--
Rik Wasmus
Nov 23 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Gadrin77 | last post: by
4 posts views Thread by Csaba Gabor | last post: by
4 posts views Thread by TJS | last post: by
1 post views Thread by trihanhcie | last post: by
2 posts views Thread by barrypalmer | last post: by
reply views Thread by XIAOLAOHU | last post: by
reply views Thread by leo001 | last post: by
reply views Thread by lumer26 | last post: by
reply views Thread by Vinnie | last post: by
1 post views Thread by lumer26 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.