471,605 Members | 1,542 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,605 software developers and data experts.

page break... html to word or email

hi all im having troubles with a form that i have created for my website (application form)

basically i need to keep the webpage, page-break settings transfered into an email.

ive used the wc3 tutorials and the following page breaks individually to attempt to get the document to split.. with no avail.


Expand|Select|Wrap|Line Numbers
  1. <p style="page-break-before:always"/>
  2.  
  3. <br clear="all" style="page-break-before:always" />
  4.  
  5. VBCRLF
here is the webpage and a copy of the php file that emails the webpage data
application.html
php file uploader1.txt
any suggestions or ideas that could help me would be very much appreciated.

cheers

--dragon
Oct 10 '07 #1
4 11928
I just had the same issue where something that used to work quit working in word I had defined (in head or CSS):
Expand|Select|Wrap|Line Numbers
  1.     H3 { page-break-before: always }
  2.  
and placed in the body where ever I wanted a break:
Expand|Select|Wrap|Line Numbers
  1. <H3><!-- Next printed page --></H3>
  2.  
Apparently comments and white space is ignored now (???) so I had to use a space like so:
Expand|Select|Wrap|Line Numbers
  1. <p style="page-break-before:always">&nbsp;</p> 
  2.  
Hughie
Nov 14 '07 #2
drhowarddrfine
7,435 Expert 4TB
Dragon,
Validate your html for your list of 26 errors that need fixing. Then validate your css for the error there.
Nov 15 '07 #3
Correction: To avoid the space at the top of the page wrap the content of the page and not the space of my original reply or add the style to the first paragraph of every page:
Expand|Select|Wrap|Line Numbers
  1. <p style="page-break-before:always">Content of next page</p> 
  2.  
Expand|Select|Wrap|Line Numbers
  1. <p style="page-break-before:always">&nbsp;</p> 
  2.  
Nov 15 '07 #4
Correction: To avoid the space at the top of the page wrap the content of the page and not the space of my original reply or add the style to the first paragraph of every page:
Expand|Select|Wrap|Line Numbers
  1. <p style="page-break-before:always">Content of next page</p> 
  2.  
cheers for the input so far.. however we have a new problem...

ok something weired happens with your line of code...
ill try to explain the best i can

after i have input the code as you described (in both ways) it goes in nice and smoothly ect...

after the form has been submitted and i receive the email with the attached form, the html/php code shows a blank line of code instead of the page break i inserted...

eg..
_________________
Expand|Select|Wrap|Line Numbers
  1. on my side
  2. '</head>
  3. '<body>
  4. '<p style="page-break-before:always">some sort of content</p>
  5. '</body>
  6. '</html>
  7.  
  8. after i receive the email:
  9. '</head>
  10. '<body>
  11.  
  12. '</body>
  13. '</html>
  14.  
___________________

thats exactly what happens and i have no idea why....

any ideas?
Jan 28 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

1 post views Thread by Matthew Robinson | last post: by
18 posts views Thread by Gustaf Liljegren | last post: by
12 posts views Thread by enak | last post: by
2 posts views Thread by moondaddy | last post: by
1 post views Thread by Erik K. Schindeldecker | last post: by
reply views Thread by MichaelMortimer | last post: by
reply views Thread by CCCYYYY | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.