468,238 Members | 1,683 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,238 developers. It's quick & easy.

IE& and Frames

3
I have built a simple HTML-only framed site that works on all other browsers tested - but not IE7.

The frame is set to have the side navigation point to the main frame with <FRAME NAME=MAIN SRC="home.html"> and each other page has <BASE TARGET="MAIN"> so that links will appear in that same frame. Instead all links appear in the first mentioned left nav.

All other browsers include IE5.2, Safari, and Firefox....
Any hints? This is driving me insane.
Apr 12 '07 #1
3 1204
drhowarddrfine
7,435 Expert 4TB
Read the stickies.
Apr 12 '07 #2
jennw
3
does this help?
---------------------------
Index Frame:
http://www.lloydwise.com

Home/ Main Frame:
http://www.lloydwise.com/home.html

Nav Frame:
http://www.lloydwise.com/nav.html
Apr 12 '07 #3
jennw
3
Just wanted all to know the answer to this problem - just in case it can help others.
I moved the base tag within the head tags and not after. This was fine on previous versions of IE and other browsers - but IE7 got pickier and needed the amendment.
Apr 13 '07 #4

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

15 posts views Thread by F. Da Costa | last post: by
6 posts views Thread by Linda Antonsson | last post: by
4 posts views Thread by Robert Secon | last post: by
2 posts views Thread by Ian Beer | last post: by
reply views Thread by Francois | last post: by
6 posts views Thread by Jim Lawton | last post: by
7 posts views Thread by Paul Lautman | last post: by
1 post views Thread by Grzegorz ¦lusarek | last post: by
2 posts views Thread by arungenesis | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.