469,628 Members | 1,049 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,628 developers. It's quick & easy.

IE7, FF2.0 background color problem

I'm wondering if there is a work-around for the following problem that
I've encountered. FireFox is behaving like I expect, IE7 is
misbehaving.

The main stylesheet has the declaration:
html, body {
margin: 0 5%;
padding: 0;
background-color: #FFFFFF;
}

In other stylesheets I have:
html, body {
background-color: #71A5DC;
}

In FF the full browser background is filled with the designated
colour. In IE only the area used and the area within the margins are
coloured. Resize the browser to >800x600 to see the effect.

The site is: http://www.hectar.net/portfolio (the site is still very
much under development so please forgive the lousy coding).

Thanks in advance.
---------------------------------------------------------------
jn******@yourpantsyahoo.com.au : Remove your pants to reply
---------------------------------------------------------------
Dec 22 '06 #1
6 10074
Jeff North wrote:
I'm wondering if there is a work-around for the following problem that
I've encountered. FireFox is behaving like I expect, IE7 is
misbehaving.

The main stylesheet has the declaration:
html, body {
margin: 0 5%;
padding: 0;
background-color: #FFFFFF;
}
Not at the time of this writing, it doesn't. I see only:
html, body {
margin: 0 5%;
padding: 0;
}
>
In other stylesheets I have:
html, body {
background-color: #71A5DC;
}

In FF the full browser background is filled with the designated
colour.
Well, not at first. When I pull in, the full browser background is
mostly my default color. It's only after I enable JavaScript, and then
think to select a color in the upper-right dropdown, that I see the
other color. In FF, this is indeed the full viewport area.
In IE only the area used and the area within the margins are
coloured. Resize the browser to >800x600 to see the effect.
Ah, now I understand the problem.
Have you tried adding height:100%; to the body, html rules?
The site is: http://www.hectar.net/portfolio
jn******@yourpantsyahoo.com.au : Remove your pants to reply
This part I like!
--
John
Dec 22 '06 #2
On Fri, 22 Dec 2006 15:53:04 +0100, in
comp.infosystems.www.authoring.stylesheets John Hosking
<Jo**@DELETE.Hosking.name.MUNGED>
<45**********@news.bluewin.chwrote:
>| Jeff North wrote:
| I'm wondering if there is a work-around for the following problem that
| I've encountered. FireFox is behaving like I expect, IE7 is
| misbehaving.
| >
| The main stylesheet has the declaration:
| html, body {
| margin: 0 5%;
| padding: 0;
| background-color: #FFFFFF;
| }
|
| Not at the time of this writing, it doesn't. I see only:
| html, body {
| margin: 0 5%;
| padding: 0;
| }
Damn!!! forgot to upload the latest stylesheet :-(
>| >
| In other stylesheets I have:
| html, body {
| background-color: #71A5DC;
| }
| >
| In FF the full browser background is filled with the designated
| colour.
|
| Well, not at first. When I pull in, the full browser background is
| mostly my default color. It's only after I enable JavaScript, and then
| think to select a color in the upper-right dropdown, that I see the
| other color. In FF, this is indeed the full viewport area.
|
| In IE only the area used and the area within the margins are
| coloured. Resize the browser to >800x600 to see the effect.
|
| Ah, now I understand the problem.
| Have you tried adding height:100%; to the body, html rules?
html, body {
background-color: #FFFFFF;
display: block;
margin: 0 5%;
padding: 0;
height: 100%;
width: auto;
}

The height:100% did the trick.
But IE7 still ignores the left/right margin. I can live with that :-)
>| The site is: http://www.hectar.net/portfolio
|
| jn******@yourpantsyahoo.com.au : Remove your pants to reply
|
| This part I like!
:-)
---------------------------------------------------------------
jn******@yourpantsyahoo.com.au : Remove your pants to reply
---------------------------------------------------------------
Dec 22 '06 #3
Jeff North wrote:
>
html, body {
background-color: #FFFFFF;
display: block;
margin: 0 5%;
padding: 0;
height: 100%;
width: auto;
}

The height:100% did the trick.
But IE7 still ignores the left/right margin. I can live with that :-)

I don't have IE7 here so I don't understand what margin problem you're
having. I have an IE6, and that looks OK to me.

I just noticed something, and I don't know if you care, but here it is
anyway. Your dropdown list for the colors shows default at the top (as,
yes, the default). What you mean is white, because that's the default
you have set for your site. But it's not really *the* default, because
every browser might have something different (I've got a nasty pink, for
example). Maybe (just maybe) you want to change "default" to "white".

--
John
Dec 22 '06 #4
Jeff North wrote:
>
http://www.hectar.net/portfolio
Are you aware that it's a bit off kilter in large window sizes? If I
maximize my window (1600x1200) the header and content area shift to the
left side, but the navigation tabs go to the right. The left/right
margins don't seem to be even, either. It looks strange.

--
Berg
Dec 23 '06 #5
On Sat, 23 Dec 2006 00:01:13 +0100, in
comp.infosystems.www.authoring.stylesheets John Hosking
<Jo**@DELETE.Hosking.name.MUNGED>
<45**********@news.bluewin.chwrote:
>| Jeff North wrote:
|
| >
| html, body {
| background-color: #FFFFFF;
| display: block;
| margin: 0 5%;
| padding: 0;
| height: 100%;
| width: auto;
| }
| >
| The height:100% did the trick.
| But IE7 still ignores the left/right margin. I can live with that :-)
|
|
| I don't have IE7 here so I don't understand what margin problem you're
| having. I have an IE6, and that looks OK to me.
|
| I just noticed something, and I don't know if you care, but here it is
| anyway. Your dropdown list for the colors shows default at the top (as,
| yes, the default). What you mean is white, because that's the default
| you have set for your site. But it's not really *the* default, because
| every browser might have something different (I've got a nasty pink, for
| example).
The 'default' stylesheet does actually set backgrounds etc to white.
Maybe you have your browser set to only use your colour scheme.
I changed the preferences in IE and FF to a background colour of black
and then reloaded the page. The entire background was white.
>| Maybe (just maybe) you want to change "default" to "white".
Hmmm, I'll think about it :-)
---------------------------------------------------------------
jn******@yourpantsyahoo.com.au : Remove your pants to reply
---------------------------------------------------------------
Jan 2 '07 #6
On Sat, 23 Dec 2006 10:47:08 -0600, in
comp.infosystems.www.authoring.stylesheets Bergamot
<be******@visi.com>
<4v*************@mid.individual.netwrote:
>| Jeff North wrote:
| >
| http://www.hectar.net/portfolio
|
| Are you aware that it's a bit off kilter in large window sizes? If I
| maximize my window (1600x1200) the header and content area shift to the
| left side, but the navigation tabs go to the right. The left/right
| margins don't seem to be even, either. It looks strange.
I've changed the CSS to now adjust for the entire screen but wont be
uploading the files for a few days yet.

BTW, I have 3 screens all set to different resolutions but I didn't
notice what you experienced. Maybe I need to go to a higher resolution
(and get a new pair of glasses/binoculars LOL).
---------------------------------------------------------------
jn******@yourpantsyahoo.com.au : Remove your pants to reply
---------------------------------------------------------------
Jan 2 '07 #7

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Chris Beall | last post: by
3 posts views Thread by MediaDesign | last post: by
11 posts views Thread by Konrad Den Ende | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.