469,904 Members | 2,518 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,904 developers. It's quick & easy.

Internet Exploder and <a> with extra space...

143 100+
Hey

IE, as usual, is being a royal pain in the backside. I have an <a> tag with the width and height defined as the same size as the image it contains. Changing the height value makes no difference in IE (just for the record) and the problem I'm having, is that it's creating what looks like maybe a 3 pixel padding below the image. You can see the outline markers of where the link extends to. If I set a background colour on the anchor, it would show through at the bottom.

In Opera and Firefox this is not the case. The <a> is nice and snug below the image, there's no unspecified padding. Does anyone else know of this behaviour or have a workaround? Note that changing the height setting of the anchor does nothing in IE.

Thanks
Dec 12 '06 #1
1 1130
steven
143 100+
Ughh, would you believe that I have to set the font-size to 0 for Internet Explorer to work correctly. Sigh.

Fixed.
Dec 12 '06 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

4 posts views Thread by Angelos | last post: by
2 posts views Thread by Donald Firesmith | last post: by
11 posts views Thread by Scott Brady Drummonds | last post: by
2 posts views Thread by Greg Donald | last post: by
1 post views Thread by Michael Primeaux | last post: by
20 posts views Thread by martin-g | last post: by
3 posts views Thread by ajay2552 | last post: by
44 posts views Thread by Zytan | last post: by
1 post views Thread by Waqarahmed | last post: by
reply views Thread by Salome Sato | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.