By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,654 Members | 1,840 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,654 IT Pros & Developers. It's quick & easy.

ie image loss

P: 2
In versions of IE 6 or previous the header and links at the top of the page will not show up.
It works fine in firefox and i think its okay in IE7.
the website is www.stepsfitness.com
i have double checked and have tried using the Star html Selector Bug in some places to the css and html but cant find why it wont show.
any ideas anywhere???
Melissa
Oct 17 '06 #1
Share this Question
Share on Google+
3 Replies


drhowarddrfine
Expert 5K+
P: 7,435
You are using html but also Xhtml end tags. Remove the slash from /> on many of your elements.

Also, you are using the transitional doctype. What are you transitioning from? New pages should always use the strict doctype.

Validate your html and css and fix those errors.
Oct 17 '06 #2

kestrel
Expert 100+
P: 1,071
sounds right

here are the validation pages

CSS - http://jigsaw.w3.org/css-validator/
(X)HTML - http://validator.w3.org/
Oct 18 '06 #3

P: 2
thanks
checking that helped a few things
i also did some more searching around with IE compatibility and added some tags such as:

#header {
position: relative;
float: left;
top: 5px;
width: auto;
height: auto;
}

html>body #header {
position: absolute;
left: 410px;
top: 5px;
width: 400px;
height: 180px;
}

This allowed the pictures to come up on both FF and IE. Apparently its a glitch with reading the absolute positoning I think.


As for the transitional- I dont even actually know what it means, but ill change it

thanks
Melissa
Oct 18 '06 #4

Post your reply

Sign in to post your reply or Sign up for a free account.