By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,759 Members | 1,251 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,759 IT Pros & Developers. It's quick & easy.

Background image not appearing

P: n/a
Hi

I have a background image on this page
http://www.siliconglen.com/craig/

which is no longer appearing, yet the image is there.

could someone let me know why it isn't appearing? I assume it's
something in the stylesheet.

thanks

--
Craig Cockburn ("coburn"). http://www.SiliconGlen.com/
Please sign the Spam Petition: http://www.siliconglen.com/spampetition/
Home to the first online guide to Scotland, founded 1994.
Scottish FAQ, weddings, website design, stop spam and more!
Dec 29 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Craig Cockburn wrote:

Hi

I have a background image on this page
http://www.siliconglen.com/craig/

which is no longer appearing, yet the image is there.

could someone let me know why it isn't appearing? I assume it's
something in the stylesheet.

thanks


Your CSS conflicts with your BODY tag. The CSS has "background:
#ffffff" for BODY, which apparently overrides the background and
bgcolor attributes on the BODY tag. Such conflicts are quite
common when attributes and style-sheets address the same display
characteristics.

I suggest you remove the attributes from the BODY tag and change
your CSS (separating html and body) to incorporate the background
image and color.

However, the image and color may cause problems for anyone with
even a mild visual handicap. The yellow-orange color makes it
difficult to distinguish the colors of links. The texture of the
background interfers with the readability of the text. All this
can be a problem for someone (me) who merely uses eyeglasses; the
page is not an "easy read". Just image how someone who is dyslexic
or partially blind might see your page.

--

David E. Ross
<http://www.rossde.com/>

Concerned about someone (e.g., Pres. Bush) snooping
into your E-mail? Use PGP.
See my <http://www.rossde.com/PGP/>
Dec 30 '05 #2

P: n/a
It seems like your stylesheet is overriding your <body> tag. Leave your body
tag at just <body> and add this to your stylesheet:

html, body {
background-image: url('http://www.siliconglen.com/images/bgcraig.gif');
color: #000000;
}
I worked on my computer.
--
Dec 30 '05 #3

P: n/a
Thanks all, works now

Craig
--
Craig Cockburn ("coburn"). http://www.SiliconGlen.com/
Please sign the Spam Petition: http://www.siliconglen.com/spampetition/
Home to the first online guide to Scotland, founded 1994.
Scottish FAQ, weddings, website design, stop spam and more!
Dec 30 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.