By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,364 Members | 1,637 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,364 IT Pros & Developers. It's quick & easy.

HELP!! document type does not allow element "META" here

P: n/a
My site did validate and now it doesn't. The error I get is the following:
document type does not allow element "META" here

....nt-type" content="text/html;charset=iso-8859-1">

Can someone please tell me what I need to change?These are the Meta tags:
</head>
<meta http-equiv="Content-type" content="text/html;charset=iso-8859-1">
<META http-equiv="PICS-Label" content=(PICS-1.1
"http://www.classify.org/safesurf/" L gen true for
"http://www.deweybeachvacation.com" r (SS~~000 7))'>

<meta name="resource-type" content="document">
<meta name="generator" content="AnyBrowser.com MetaMaker">
<meta http-equiv="pragma" content="no-cache">
<meta name="revisit-after" content="15 days">
<meta name="classification" content="Recreational">
<meta name="MSSmartTagsPreventParsing" content="TRUE">

<META Name="Keywords" Content="dewey beach delaware, dewey beach rentals,
vacation rentals, dewey beach vacation rentals, beach, hotels, rentals,
apartments,summer rentals, ocean view, summer vacation, summer vacation rental,
seasonal,fishing, east coast, Rehoboth, Rehobeth, outlet shopping, Rusty
Rudder,Lewes">
<META Name="Description" Content="Dewey Beach vacation rentals 2 & 3 bedroom
ocean view apartments for weekly summer rentals. 100 feet to beach, close to
Rehoboth">
<META Name="Author" Content="Dell">
<META Name="Robots" Content="index,follow">
<META Name="Googlebot" Content="index,follow">

Why won't this validate now?
If you need to view the site the address is: www.deweybeachvacation.com
Thanks,
Dell
Jul 23 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
RodneyDunes <ro*********@aol.com> wrote:
My site did validate and now it doesn't. The error I get is the following:
document type does not allow element "META" here

...nt-type" content="text/html;charset=iso-8859-1">

Can someone please tell me what I need to change?These are the Meta tags:
</head>
<meta http-equiv="Content-type" content="text/html;charset=iso-8859-1">


The META element can only go inside the HEAD element. You've already closed
the HEAD element with the </head> tag. Move your META elements inside the
HEAD element (before the </head> tag).
--
Darin McGrew, mc****@stanfordalumni.org, http://www.rahul.net/mcgrew/
Web Design Group, da***@htmlhelp.com, http://www.HTMLHelp.com/

"I used to have a handle on life, but it broke."
Jul 23 '05 #2

P: n/a
Once upon a time *RodneyDunes* wrote:
My site did validate and now it doesn't. The error I get is the following:
document type does not allow element "META" here

...nt-type" content="text/html;charset=iso-8859-1">

Can someone please tell me what I need to change?These are the Meta tags:
</head>
<meta http-equiv="Content-type" content="text/html;charset=iso-8859-1">
<snip>
Why won't this validate now?
If you need to view the site the address is: www.deweybeachvacation.com
Thanks,


You mean the pages at
http://www.angelfire.com/biz7/rodney...eweybeach.html ?

All META must be abowe </head> not below it, and below <head>

E.g.
<head>
<meta http-equiv="Content-type" content="text/html;charset=iso-8859-1">
</head>

--
/Arne
http://web.telia.com/~u97802964/

If you owe the bank a million, you have a problem.
If you owe the bank ten million, the bank has a problem! (Unknown)
Jul 23 '05 #3

P: n/a
RodneyDunes wrote:
My site did validate and now it doesn't.


There are two more animated gifs out there that you haven't used yet.
Place those on your page, and it will validate.

--
-bts
-This space intentionally left blank.
Jul 23 '05 #4

P: n/a
RodneyDunes wrote:
My site did validate and now it doesn't. The error I get is the following:
document type does not allow element "META" here


The "here" is the essential part of the message. Everything in an HTML
document (except comments and the HTML tags themselves) belongs either
in the head or in the body. For some reason you have the META tags in
neither. Put them in the head where they belong.
Jul 23 '05 #5

P: n/a
Dan

RodneyDunes wrote:
<meta http-equiv="Content-type"

content="text/html;charset=iso-8859-1">

You're better off replacing this one with an actual HTTP header
(perhaps supplied via a .htaccess file), anyway.

--
Dan

Jul 23 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.