By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,706 Members | 2,030 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,706 IT Pros & Developers. It's quick & easy.

An error message... "Content is not allowed in prolog."

P: n/a
Well, the error message...

"Please, validate your XML document first!
Line 1

Column 1

Content is not allowed in prolog."

comes up when I try to verify my CSS...

I know, I know... this is html newsgroup... but the problem is in the html
file being saved as UTF-8 by windows notepad.

Of course, when I look at the file with a hex editor I see three bytes
before the first '<' (I expect to see the '<' as the first byte, not the
fouth byte.

So, is this a problem or have I done something wrong.

I swear this 'character encoding', 'character repertoire', font selection
mularky is the most convoluted crock of shit I have ever seen in ALL of my
experiences...
--
--
Ri*************@comcast.net
http://RichardRPlourde.home.comcast.net
Jul 23 '05 #1
Share this Question
Share on Google+
10 Replies


P: n/a
On Sun, 12 Sep 2004 02:27:54 -0400, Richard R Plourde
<Se*********@hotmail.com> wrote:
"Please, validate your XML document first!
Line 1

Column 1

Content is not allowed in prolog."


Don't you think we can benefit from a URL?? Come on, we aren't friggin'
clairvoyant!
Jul 23 '05 #2

P: n/a
> Don't you think we can benefit from a URL?? Come on, we aren't friggin'
clairvoyant!


on the last line of the post.................

unless of course you want this....

http://jigsaw.w3.org/css-validator/v...net/index.html


Jul 23 '05 #3

P: n/a
"Richard R Plourde" <Se*********@hotmail.com> wrote:
I know, I know... this is html newsgroup... but the problem is in the
html file being saved as UTF-8 by windows notepad.

Of course, when I look at the file with a hex editor I see three bytes
before the first '<' (I expect to see the '<' as the first byte, not
the fouth byte.
Windows Notepad always adds a UTF-8 byte-order mark (ef bb bf),
even though it's not required and causes errors in non-Microsoft
tools that aren't expecting it.

You could either:

Use a different GUI editor like Unipad (http://www.unipad.org/)

Use Notepad to compose your file, then use "vi" or a hex editor
to strip the first three characters.
--;K

Jul 23 '05 #4

P: n/a
Richard R Plourde wrote:

"Please, validate your XML document first!
Line 1
Column 1
Content is not allowed in prolog."

It does not think you have a valid XML document. You could:
1. Remove the XML header.
2. Use the file upload method validate your CSS.

BTW: Why would we know to use the URL in your signature?

--
jmm dash list (at) sohnen-moe (dot) com
(Remove .AXSPAMGN for email)
Jul 23 '05 #5

P: n/a
> "Richard R Plourde" <Se*********@hotmail.com> wrote:
I know, I know... this is html newsgroup... but the problem is in the
html file being saved as UTF-8 by windows notepad. Of course, when I look at the file with a hex editor I see three bytes
before the first '<' (I expect to see the '<' as the first byte, not
the fouth byte.

"Mad Bad Rabbit" <ma**********@yahoo.com> wrote in message
news:tu********************@texas.net...
Windows Notepad always adds a UTF-8 byte-order mark (ef bb bf),
even though it's not required and causes errors in non-Microsoft
tools that aren't expecting it.
So, does this mean it's valid or not? ;-) <just kidding>
You could either:

Use a different GUI editor like Unipad (http://www.unipad.org/)
For $199.00 we'll strip those three bytes for you... and just to prove we
are 'good guys' we'll only make it a 'one time charge'... $-)
Use Notepad to compose your file, then use "vi" or a hex editor
to strip the first three characters.


Thanks, now I need to figure out which one of the 7 editors I downloaded
does hex... ;-)

Rich
Jul 23 '05 #6

P: n/a
> Richard R Plourde wrote:
"Please, validate your XML document first!
Line 1
Column 1
Content is not allowed in prolog."

"jmm-list-gn" <jm***************@sohnen-moe.com> wrote in message
news:tP********************@giganews.com...
It does not think you have a valid XML document. You could:
1. Remove the XML header.
Huh???
2. Use the file upload method validate your CSS.
Not answering the question. (Hint the question was... is this a problem or
have I done something wrong)
BTW: Why would we know to use the URL in your signature?


http://RichardRPlourde.home.comcast.net

ALL the files there had the three bytes... I told you the situation, and all
I was looking for was an evaluation of who dropped the ball 'me or them'...

Thanks,

Rich

OBTW... I made a note here to...
spn fd jmm
Jul 23 '05 #7

P: n/a
On Sun, 12 Sep 2004, Richard R Plourde wrote:
I was looking for was an evaluation of who dropped the ball 'me or them'...


It's not as easy as that! The definition of whether a BOM was
expected/allowed in a file that's encoded in utf-8 hasn't always
been clearly codified.

It is now: if you look at table 2-3 in chapter 2
http://www.unicode.org/versions/Unicode4.0.0/ch02.pdf
then it says clearly that BOM is allowed.

So unless XML has some extra rule which excludes it, I'd say you can
report a bug (after checking to see it hasn't already been).

But first, google for the terms such as > xml utf-8 bom < , maybe toss
in "validator" and so on, and check the recent history... I found
this http://lists.xml.org/archives/xml-de.../msg00095.html

(Sorry, I haven't been following this thread in detail, so apologies
to anyone if I'm repearing what they already posted.) Hth.

Jul 23 '05 #8

P: n/a
"Richard R Plourde" <Se*********@hotmail.com> wrote:
"Mad Bad Rabbit" <ma**********@yahoo.com> wrote:
Windows Notepad always adds a UTF-8 byte-order mark (ef bb bf),
even though it's not required and causes errors in non-Microsoft
tools that aren't expecting it.
You could either:
Use a different GUI editor like Unipad (http://www.unipad.org/)


For $199.00 we'll strip those three bytes for you...


Here's some more Unicode-capable editors, some of them freeware:

http://www.alanwood.net/unicode/utilities_editors.html
--;K

Jul 23 '05 #9

P: n/a
"Richard R Plourde" <Se*********@hotmail.com> wrote:
For $199.00 we'll strip those three bytes for you...


"Mad Bad Rabbit" <ma**********@yahoo.com> wrote in message
news:Hs********************@texas.net...
Here's some more Unicode-capable editors, some of them freeware: http://www.alanwood.net/unicode/utilities_editors.html


Excellent... thanks for the link...

Rich
Jul 23 '05 #10

P: n/a
In article <Pi******************************@ppepc56.ph.gla.a c.uk>,
"Alan J. Flavell" <fl*****@ph.gla.ac.uk> wrote:
So unless XML has some extra rule which excludes it, I'd say you can
report a bug (after checking to see it hasn't already been).


XML allows the UTF-8 BOM. IIRC, it was allowed in 2nd ed., because
fighting the Microsoftism would have been futile.

--
Henri Sivonen
hs******@iki.fi
http://iki.fi/hsivonen/
Mozilla Web Author FAQ: http://mozilla.org/docs/web-developer/faq.html
Jul 23 '05 #11

This discussion thread is closed

Replies have been disabled for this discussion.