467,920 Members | 1,223 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,920 developers. It's quick & easy.

CSS overlay and MSIE 6

Hi,

Does somebody have an idea why MSIE 6 on this page

http://www.nies.ch/switzerland/fauna/index.de.php/2

does not show the "New" icon in the lower right corner of the thumbnail
like in any other browser?

The XHTML 1.1 code:

==CUT==
<table class="thumb">
<tr>
<td><a href="..."><img src="..." width="100" height="67" /><span
class="new"><img src="/pic/new2.gif" width="22" height="8" alt="New!"
/></span></a></td>
</tr>
</table>
==CUT==

The CSS 2.1 code:

==CUT==
table.thumb
{ margin-top: 0px;
margin-bottom: 0px;
margin-left: auto;
margin-right: auto;
border-spacing: 1px;
}
table.thumb td
{ width: 112px;
height: 112px;
vertical-align: middle;
text-align: center;
padding: 0px;
margin: 0px;
background-position: center;
background-repeat: no-repeat;
}
table.thumb img
{ border: 0px;
margin: 0px;
padding: 0px;
vertical-align: bottom;
text-align: center;
}
span.new
{ padding: 0px;
margin: 0px;
border: 0px;
width: 22px;
height: 8px;
margin-left: -22px;
margin-bottom: -1px;
}
span.new img
{ border: 0px;
border-spacing: 0px;
padding: 0px;
margin: 0px;
}
==CUT==

Thanks in advance,

Regards,
Bernd

Jul 21 '05 #1
  • viewed: 4588
Share:
2 Replies


Bernd Nies wrote:

Does somebody have an idea why MSIE 6 on this page

http://www.nies.ch/switzerland/fauna/index.de.php/2

does not show the "New" icon in the lower right corner of the thumbnail
like in any other browser?

The XHTML 1.1 code:


XHTML 1.1 should not be served as text/html.
Use HTML 4.01 and your problem goes away. Or if you insist on using
XHTML and serving it as text/html then remove the XML declaration line
(i.e. <?xml version="1.0" encoding="utf-8"?>) from the document as it
throws IE 6 into quirks mode.
--

Martin Honnen
http://JavaScript.FAQTs.com/
Jul 21 '05 #2
Hi Martin,

Martin Honnen schrieb:
XHTML 1.1 should not be served as text/html.
Use HTML 4.01 and your problem goes away. Or if you insist on using
XHTML and serving it as text/html then remove the XML declaration line
(i.e. <?xml version="1.0" encoding="utf-8"?>) from the document as it
throws IE 6 into quirks mode.


Thanks for that hint. I converted it to HTML 4.01 and now even @%&$!
internet exploder displays it correctly.

Regards,
Bernd

Jul 21 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Never Best | last post: by
1 post views Thread by sendhil | last post: by
reply views Thread by odie5533 | last post: by
9 posts views Thread by Chuck Anderson | last post: by
3 posts views Thread by EnigmaticSource | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.