469,357 Members | 1,802 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,357 developers. It's quick & easy.

Getting sqlcode -305 instead of 100 while fetch

1
Hi,

I am trying to fetch a cursor, in a select statement I am selecting a field which can have Null values.

The record which I am fetching is not present in the DB2 table. Hence on fetch I expect sqlcode of 100 however I am getting the sqlcode of 305-. I am doing this in a program.

Other details: If I run same sql in spufi without any cursor I get sql code 100 which is right as the record doesn't exist in the table.

However if I run the same query in an program using cursor I get sqlcode 305-. I am using one more cursore before this and checking the retrun code 0 to enter in the above cursor where I am getting sqlcode -305.

Kindly let me know the cause for the same.

Regards,
Amrish
Apr 17 '15 #1
0 1477

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

10 posts views Thread by scoonie999 | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.