468,251 Members | 1,391 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,251 developers. It's quick & easy.

DB2 RTCL for linux

I'm looking for a DB2 runtime client for gentoo linux without X, that
is, command line only. All I want to do is regularly run a few simple
queries against DB2 on another server.

I see RTCL downloads for v8 but they all require a base install of DB2
v8 and I haven't found a free version of the base install for download.
All old links to same now seem to return a 404.
DB2 UDB v9 doesn't seem to have a RTCL for linux only for windows.

Any ideas how to do this?

Thanks.
Aug 30 '08 #1
8 3673
Johnny wrote:
I'm looking for a DB2 runtime client for gentoo linux without X, that
is, command line only. All I want to do is regularly run a few simple
queries against DB2 on another server.

I see RTCL downloads for v8 but they all require a base install of DB2
v8 and I haven't found a free version of the base install for download.
All old links to same now seem to return a 404.
DB2 UDB v9 doesn't seem to have a RTCL for linux only for windows.

Any ideas how to do this?

Thanks.
Mostly solved: Just found: It seems for v9 they changed the name from
DB2 Runtime Client to IBM Data Server Runtime Client. Downloaded and
installed without incident. All I have to do now is configure and run.
Aug 30 '08 #2
Johnny wrote:
Mostly solved: Just found: It seems for v9 they changed the name from
DB2 Runtime Client to IBM Data Server Runtime Client.
...right..works against IDS and Derby hence the name change.
--
Serge Rielau
DB2 Solutions Development
IBM Toronto Lab
Aug 30 '08 #3
Johnny wrote:
I see RTCL downloads for v8 but they all require a base install of DB2
v8 and I haven't found a free version of the base install for download.
All old links to same now seem to return a 404.
DB2 UDB v9 doesn't seem to have a RTCL for linux only for windows.
FYI - the "RTCL" downloads for v8 do NOT require a base install of DB2.
They're refreshes - meaning full installs.

And if you're just going with it now, I suggest getting the 9.5 client
instead of the 9.1 (aka "DB2 9") client. As long as it's free anyway, may
as well get the latest, which should be 9.5fp2.
Aug 30 '08 #4
Darin McBride wrote:
Johnny wrote:
>I see RTCL downloads for v8 but they all require a base install of DB2
v8 and I haven't found a free version of the base install for download.
All old links to same now seem to return a 404.
DB2 UDB v9 doesn't seem to have a RTCL for linux only for windows.

FYI - the "RTCL" downloads for v8 do NOT require a base install of DB2.
They're refreshes - meaning full installs.
That was not my experience.
For instance here's what the latest v8 RTCL
labelled "Runtime Client Language Independent" and with download link
ftp://ftp.software.ibm.com/ps/produc...00207_RTCL.tar
as shown on this page here:
http://www-01.ibm.com/support/docvie...id=swg21256051
fails like this when I try to install it:
----------------------
./db2_install
Specify one or more of the following keywords,
separated by spaces, to install DB2 products.

Keyword Product Description
DB2.RTCL DB2 Run-time Client for LINUX26

Enter "help" to redisplay product names.

Enter "quit" to exit.

************************************************** *********
DB2.RTCL
IBM_db2msen81...
error: Failed dependencies:
/opt/IBM/db2/V8.1 is needed by IBM_db2msen81-8.1.2-144.i386
The installation logfile can be found in /tmp/db2_install_log.20167.

db2_install program terminated prematurely.
----------------------

Also it says on the side bar "Prerequisite: V8.1 GA" but maybe I
missed something or have found the wrong version.

Fortunately v9.5 installs for me w/o a problem once I understood they
had changed the name.
>
And if you're just going with it now, I suggest getting the 9.5 client
instead of the 9.1 (aka "DB2 9") client. As long as it's free anyway, may
as well get the latest, which should be 9.5fp2.
Thanks Darin I will go with the latest 9.5 as you suggest.
Sep 2 '08 #5
Johnny wrote:
DB2.RTCL
IBM_db2msen81...
error: Failed dependencies:
/opt/IBM/db2/V8.1 is needed by IBM_db2msen81-8.1.2-144.i386
The installation logfile can be found in /tmp/db2_install_log.20167.
The info in this message indicates that the installer is looking for a
directory (not a file) and can't access it - are you sure /opt/IBM/db2/V8.1
exists? What user are you installing as? You may need root privileges to
access or write to the indicated directory or it may not exist - or that
it's looking for a previous installation. Been down that road too many
times lately.

--
Will Honea
** Posted from http://www.teranews.com **
Sep 3 '08 #6
Johnny wrote:
Darin McBride wrote:
>Johnny wrote:
>>I see RTCL downloads for v8 but they all require a base install of DB2
v8 and I haven't found a free version of the base install for download.
All old links to same now seem to return a 404.
DB2 UDB v9 doesn't seem to have a RTCL for linux only for windows.

FYI - the "RTCL" downloads for v8 do NOT require a base install of DB2.
They're refreshes - meaning full installs.

That was not my experience.
For instance here's what the latest v8 RTCL
labelled "Runtime Client Language Independent" and with download link
ftp://ftp.software.ibm.com/ps/produc...00207_RTCL.tar
as shown on this page here:
http://www-01.ibm.com/support/docvie...id=swg21256051
fails like this when I try to install it:
----------------------
./db2_install
The fact that this exists proves it's a full install (or an alternate fixpak
install). Deltas do not have db2_install.
DB2.RTCL
IBM_db2msen81...
error: Failed dependencies:
/opt/IBM/db2/V8.1 is needed by IBM_db2msen81-8.1.2-144.i386
The installation logfile can be found in /tmp/db2_install_log.20167.
This is bizarre. I've never seen this error message from RPM before.
Perhaps /opt/IBM/db2 isn't on a local file system, and NFS is preventing you
from writing to it, not really sure what could cause such a weird error.
Also it says on the side bar "Prerequisite: V8.1 GA" but maybe I
missed something or have found the wrong version.
Yeah, I suppose that's a bit confusing ;-)
Fortunately v9.5 installs for me w/o a problem once I understood they
had changed the name.
I find the DB2 9 and 9.5 installers to be much more robust, partly because
of the abandonment of RPM ;-)
>And if you're just going with it now, I suggest getting the 9.5 client
instead of the 9.1 (aka "DB2 9") client. As long as it's free anyway,
may as well get the latest, which should be 9.5fp2.

Thanks Darin I will go with the latest 9.5 as you suggest.
Sep 3 '08 #7
Will Honea wrote:
Johnny wrote:
>DB2.RTCL
IBM_db2msen81...
error: Failed dependencies:
/opt/IBM/db2/V8.1 is needed by IBM_db2msen81-8.1.2-144.i386
The installation logfile can be found in /tmp/db2_install_log.20167.

The info in this message indicates that the installer is looking for a
directory (not a file) and can't access it - are you sure /opt/IBM/db2/V8.1
exists? What user are you installing as? You may need root privileges to
access or write to the indicated directory or it may not exist - or that
it's looking for a previous installation. Been down that road too many
times lately.
thanks but that seems to be there:
# ls -l /opt/IBM/db2/
total 4
drwxr-xr-x 2 root root 4096 Jul 23 17:23 V8.1

and # whoami
root

I tried temporarily setting that directory to 0777 but same result.
I'm told that these are full installs so should not need a previous install.
So I am at a loss about the v8 install.
Sep 3 '08 #8
Darin McBride wrote:
Johnny wrote:
>Darin McBride wrote:
>>Johnny wrote:

I see RTCL downloads for v8 but they all require a base install of DB2
v8 and I haven't found a free version of the base install for download.
All old links to same now seem to return a 404.
DB2 UDB v9 doesn't seem to have a RTCL for linux only for windows.
FYI - the "RTCL" downloads for v8 do NOT require a base install of DB2.
They're refreshes - meaning full installs.
That was not my experience.
For instance here's what the latest v8 RTCL
labelled "Runtime Client Language Independent" and with download link
ftp://ftp.software.ibm.com/ps/produc...00207_RTCL.tar
as shown on this page here:
http://www-01.ibm.com/support/docvie...id=swg21256051
fails like this when I try to install it:
----------------------
./db2_install

The fact that this exists proves it's a full install (or an alternate fixpak
install). Deltas do not have db2_install.
>DB2.RTCL
IBM_db2msen81...
error: Failed dependencies:
/opt/IBM/db2/V8.1 is needed by IBM_db2msen81-8.1.2-144.i386
The installation logfile can be found in /tmp/db2_install_log.20167.

This is bizarre. I've never seen this error message from RPM before.
Perhaps /opt/IBM/db2 isn't on a local file system, and NFS is preventing you
from writing to it, not really sure what could cause such a weird error.
/opt/IBM/db2/ is local and is writable and am running as root but it's
not RPM it's a shell script that the error is coming from. AFAIK RPM is
not being used within this script although I do have a version of RPM
installed (I'm on gentoo linux).

My suspicion is that the v8 install is looking for more than an empty
directory.
<snip>
Sep 3 '08 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Jhuola Hoptire | last post: by
5 posts views Thread by cranium.2003 | last post: by
8 posts views Thread by shenanwei | last post: by
1 post views Thread by rada.lambretha | last post: by
reply views Thread by NPC403 | last post: by
reply views Thread by zattat | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.