By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,179 Members | 2,175 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,179 IT Pros & Developers. It's quick & easy.

db2 connect 4 minut delay after adding partitions

P: n/a
Hi!

I have a previous post on the subject that connect takes a long time.

I uninstalled db2 completely.
Installed V9.5
Installed fixpack 1
created das
created an instance
installed database sample.
Tested to connect to sample from DB2 CC - Worked OK
Stopped db2.
configured UDB to use Openssh following Liam Finnies step-by-step
guide
Updated db2nodes.cfg:
0 myhost 0
1 myhost 1
2 myhost 2
Started db2
tested "db2_all echo hi" and "db2_all db2_all echo hi" OK
Tried to connect to db SAMPLE .....................
alas, a 4 minute delay from DB2CC or db2 client on other server.
Connection via jdbc (DBVisualizer) still works OK
Obviously, the partitioning feature or ssh has something to do with
the problem.

We have a similar configuration in our test environment but on V9.1
and it works OK.
/dg


Jun 27 '08 #1
Share this Question
Share on Google+
5 Replies


P: n/a
On May 6, 7:45 am, danfa...@hotmail.com wrote:
Hi!

I have a previous post on the subject that connect takes a long time.

I uninstalled db2 completely.
Installed V9.5
Installed fixpack 1
created das
created an instance
installed database sample.
Tested to connect to sample from DB2 CC - Worked OK
Stopped db2.
configured UDB to use Openssh following Liam Finnies step-by-step
guide
Updated db2nodes.cfg:
0 myhost 0
1 myhost 1
2 myhost 2
Started db2
tested "db2_all echo hi" and "db2_all db2_all echo hi" OK
Tried to connect to db SAMPLE .....................
alas, a 4 minute delay from DB2CC or db2 client on other server.
Connection via jdbc (DBVisualizer) still works OK
Obviously, the partitioning feature or ssh has something to do with
the problem.

We have a similar configuration in our test environment but on V9.1
and it works OK.
/dg
Hello,

I can't say where the delay is coming from.... but I can say that it's
not from configuring the server to use ssh. Configuring the server to
use ssh (via DB2RSHCMD=/usr/bin/ssh) only affects db2start/db2stop
processing (and commands invoked by db2_all/rah). After that point,
FCM is used to communicate between the different database partitions.
So, connecting to a database will not involve ssh (at least on the
server), so the delay must be coming from somewhere else.

Do you see the same delay if you explicitly select a partition to
connect to? i.e. 'export DB2NODE=0 ; db2 connect to SAMPLE'? What if
you replace 'myhost' in your db2nodes.cfg with the fully-qualified
domain name?

Cheers,
Liam.
Jun 27 '08 #2

P: n/a
On May 6, 2:43*pm, Liam Finnie <lfin...@ca.ibm.comwrote:
On May 6, 7:45 am, danfa...@hotmail.com wrote:


Hi!
I have a previous post on the subject that connect takes a long time.
I uninstalled db2 completely.
Installed V9.5
Installed fixpack 1
created das
created an instance
installed database sample.
Tested to connect to sample from DB2 CC - Worked OK
Stopped db2.
configured UDB to use Openssh following Liam Finnies step-by-step
guide
Updated db2nodes.cfg:
0 myhost 0
1 myhost 1
2 myhost 2
Started db2
tested "db2_all *echo hi" *and "db2_all *db2_all echo hi" * *OK
Tried to connect to db SAMPLE .....................
alas, a *4 minute delay from DB2CC or db2 client on other server.
Connection via jdbc (DBVisualizer) *still works OK
Obviously, the partitioning feature or ssh has something to do with
the problem.
We have a similar configuration in our test environment but on V9.1
and it works OK.
/dg

Hello,

I can't say where the delay is coming from.... but I can say that it's
not from configuring the server to use ssh. *Configuring the server to
use ssh (via DB2RSHCMD=/usr/bin/ssh) only affects db2start/db2stop
processing (and commands invoked by db2_all/rah). *After that point,
FCM is used to communicate between the different database partitions.
So, connecting to a database will not involve ssh (at least on the
server), so the delay must be coming from somewhere else.

Do you see the same delay if you explicitly select a partition to
connect to? *i.e. 'export DB2NODE=0 ; db2 connect to SAMPLE'? *What if
you replace 'myhost' in your db2nodes.cfg with the fully-qualified
domain name?

Cheers,
Liam.- Hide quoted text -

- Show quoted text -
Thanks Liam, but none of the suggested changes made any difference.
I will open a PMR
/dg
Jun 27 '08 #3

P: n/a
Lew
Does it also take that long to activate the database? By changing it
to a multipartition database you have increased the memory load on
your server. It is possible that you have overallocated memory on the
machine causing os paging as the database becomes active

On May 7, 1:35 am, danfa...@hotmail.com wrote:
On May 6, 2:43 pm, Liam Finnie <lfin...@ca.ibm.comwrote:
On May 6, 7:45 am, danfa...@hotmail.com wrote:
Hi!
I have a previous post on the subject that connect takes a long time.
I uninstalled db2 completely.
Installed V9.5
Installed fixpack 1
created das
created an instance
installed database sample.
Tested to connect to sample from DB2 CC - Worked OK
Stopped db2.
configured UDB to use Openssh following Liam Finnies step-by-step
guide
Updated db2nodes.cfg:
0 myhost 0
1 myhost 1
2 myhost 2
Started db2
tested "db2_all echo hi" and "db2_all db2_all echo hi" OK
Tried to connect to db SAMPLE .....................
alas, a 4 minute delay from DB2CC or db2 client on other server.
Connection via jdbc (DBVisualizer) still works OK
Obviously, the partitioning feature or ssh has something to do with
the problem.
We have a similar configuration in our test environment but on V9.1
and it works OK.
/dg
Hello,
I can't say where the delay is coming from.... but I can say that it's
not from configuring the server to use ssh. Configuring the server to
use ssh (via DB2RSHCMD=/usr/bin/ssh) only affects db2start/db2stop
processing (and commands invoked by db2_all/rah). After that point,
FCM is used to communicate between the different database partitions.
So, connecting to a database will not involve ssh (at least on the
server), so the delay must be coming from somewhere else.
Do you see the same delay if you explicitly select a partition to
connect to? i.e. 'export DB2NODE=0 ; db2 connect to SAMPLE'? What if
you replace 'myhost' in your db2nodes.cfg with the fully-qualified
domain name?
Cheers,
Liam.- Hide quoted text -
- Show quoted text -

Thanks Liam, but none of the suggested changes made any difference.
I will open a PMR
/dg
Jun 27 '08 #4

P: n/a
On May 8, 12:48*pm, Lew <seth...@yahoo.comwrote:
Does it also take that long to activate the database? *By changing it
to a multipartition database you have increased the memory load on
your server. *It is possible that you have overallocated memory on the
machine causing os paging as the database becomes active

On May 7, 1:35 am, danfa...@hotmail.com wrote:
On May 6, 2:43 pm, Liam Finnie <lfin...@ca.ibm.comwrote:
On May 6, 7:45 am, danfa...@hotmail.com wrote:
Hi!
I have a previous post on the subject that connect takes a long time..
I uninstalled db2 completely.
Installed V9.5
Installed fixpack 1
created das
created an instance
installed database sample.
Tested to connect to sample from DB2 CC - Worked OK
Stopped db2.
configured UDB to use Openssh following Liam Finnies step-by-step
guide
Updated db2nodes.cfg:
0 myhost 0
1 myhost 1
2 myhost 2
Started db2
tested "db2_all *echo hi" *and "db2_all *db2_all echo hi" * *OK
Tried to connect to db SAMPLE .....................
alas, a *4 minute delay from DB2CC or db2 client on other server.
Connection via jdbc (DBVisualizer) *still works OK
Obviously, the partitioning feature or ssh has something to do with
the problem.
We have a similar configuration in our test environment but on V9.1
and it works OK.
/dg
Hello,
I can't say where the delay is coming from.... but I can say that it's
not from configuring the server to use ssh. *Configuring the server to
use ssh (via DB2RSHCMD=/usr/bin/ssh) only affects db2start/db2stop
processing (and commands invoked by db2_all/rah). *After that point,
FCM is used to communicate between the different database partitions.
So, connecting to a database will not involve ssh (at least on the
server), so the delay must be coming from somewhere else.
Do you see the same delay if you explicitly select a partition to
connect to? *i.e. 'export DB2NODE=0 ; db2 connect to SAMPLE'? *What if
you replace 'myhost' in your db2nodes.cfg with the fully-qualified
domain name?
Cheers,
Liam.- Hide quoted text -
- Show quoted text -
Thanks Liam, but none of the suggested changes made any difference.
I will open a PMR
/dg- Hide quoted text -

- Show quoted text -
Everything works OK locally on the server.
Note also that connect with jdbc is fast.
Even though an initial connect has been made in DB2CC (after a 4
minute delay),
DB2CC performs a new authentication every now and then and each time
it takes 4 minutes.
/dg
Jun 27 '08 #5

P: n/a
Lew
Another thing you might check is make sure that the database is
configured explicitly to authentication server on the client. I
didn't think this was an issue any more but maybe it will help.
On May 8, 7:08 am, danfa...@hotmail.com wrote:
On May 8, 12:48 pm, Lew <seth...@yahoo.comwrote:
Does it also take that long to activate the database? By changing it
to a multipartition database you have increased the memory load on
your server. It is possible that you have overallocated memory on the
machine causing os paging as the database becomes active
On May 7, 1:35 am, danfa...@hotmail.com wrote:
On May 6, 2:43 pm, Liam Finnie <lfin...@ca.ibm.comwrote:
On May 6, 7:45 am, danfa...@hotmail.com wrote:
Hi!
I have a previous post on the subject that connect takes a long time.
I uninstalled db2 completely.
Installed V9.5
Installed fixpack 1
created das
created an instance
installed database sample.
Tested to connect to sample from DB2 CC - Worked OK
Stopped db2.
configured UDB to use Openssh following Liam Finnies step-by-step
guide
Updated db2nodes.cfg:
0 myhost 0
1 myhost 1
2 myhost 2
Started db2
tested "db2_all echo hi" and "db2_all db2_all echo hi" OK
Tried to connect to db SAMPLE .....................
alas, a 4 minute delay from DB2CC or db2 client on other server.
Connection via jdbc (DBVisualizer) still works OK
Obviously, the partitioning feature or ssh has something to do with
the problem.
We have a similar configuration in our test environment but on V9.1
and it works OK.
/dg
Hello,
I can't say where the delay is coming from.... but I can say that it's
not from configuring the server to use ssh. Configuring the server to
use ssh (via DB2RSHCMD=/usr/bin/ssh) only affects db2start/db2stop
processing (and commands invoked by db2_all/rah). After that point,
FCM is used to communicate between the different database partitions.
So, connecting to a database will not involve ssh (at least on the
server), so the delay must be coming from somewhere else.
Do you see the same delay if you explicitly select a partition to
connect to? i.e. 'export DB2NODE=0 ; db2 connect to SAMPLE'? What if
you replace 'myhost' in your db2nodes.cfg with the fully-qualified
domain name?
Cheers,
Liam.- Hide quoted text -
- Show quoted text -
Thanks Liam, but none of the suggested changes made any difference.
I will open a PMR
/dg- Hide quoted text -
- Show quoted text -

Everything works OK locally on the server.
Note also that connect with jdbc is fast.
Even though an initial connect has been made in DB2CC (after a 4
minute delay),
DB2CC performs a new authentication every now and then and each time
it takes 4 minutes.
/dg
Jun 27 '08 #6

This discussion thread is closed

Replies have been disabled for this discussion.