By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,130 Members | 2,228 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,130 IT Pros & Developers. It's quick & easy.

DROP system stored procedure restriction

P: 16
Hello everybody,

I am running DB2 on linux ....

I need to import a huge table to the database I created and I found out that I have not enough BLOB size (I hope I have 320k - it should be default) ... the table is stored in .ixf format (the source db is on mainframe) and it has 180 columns.

The error I got and the explanation how to correct it is here: http://publib.boulder.ibm.com/infoce...p/trs20002.htm

nice one - but I have a problem with this solution - I am not sure if I am not wrong, but since the procedure ICMUPDATEITEMS doesnt exist, IMHO the whole description should be SYSIBM.ICMCREATEITEMS, no?

but another problem appeared - seems that this object exists but it cannot be changed ...

The outputs:

Expand|Select|Wrap|Line Numbers
  1. [db2inst1@xxxxx db2inst1]$ db2 DROP PROCEDURE ICMCREATEITEMS
  2. DB21034E  The command was processed as an SQL statement because it was not a
  3. valid Command Line Processor command.  During SQL processing it returned:
  4. SQL0204N  "DB2INST1.ICMCREATEITEMS" is an undefined name.  SQLSTATE=42704
  5.  
  6. [db2inst1@xxxxx db2inst1]$ db2 DROP PROCEDURE SYSIBM.ICMCREATEITEMS
  7. DB21034E  The command was processed as an SQL statement because it was not a
  8. valid Command Line Processor command.  During SQL processing it returned:
  9. SQL0607N  "DROP PROCEDURE" is not defined for system objects.  SQLSTATE=42832
Pls is there anybody who can help me with advise how to avoid SQLSTATE=42832 or is there any other way how to change BLOB size?

Thanks a lot for any help
Apr 8 '08 #1
Share this Question
Share on Google+
2 Replies


P: 16
It is solved ... I was importing (using import command) with "insert into" statement and I had bad informations about the data format

The IMPORT command with "create into" statement solved the problem
Apr 16 '08 #2

docdiesel
Expert 100+
P: 297
Hi,

and thank you for sharing the solution! By the way, I took the liberty to add some code tags to your first post for better readability.

Regards,

Bernd
Apr 16 '08 #3

Post your reply

Sign in to post your reply or Sign up for a free account.