472,959 Members | 1,792 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,959 software developers and data experts.

Restore DB2 9.1 backup problem


I am trying to restore a DB2 9.1 fp2 backup to another DB2 9.1 fp2 machine, both are on Windows.

Expand|Select|Wrap|Line Numbers
  1. C:\Program Files\IBM\SQLLIB\BIN>db2 -tvf C:\db2_data\test.db2
  3. DB20000I The UPDATE COMMAND OPTIONS command completed successfully.
  6. DB20000I The SET CLIENT command completed successfully.
  9. DB20000I The SET CLIENT command completed successfully.
  13. SQL1277W A redirected restore operation is being performed. Table space
  14. configuration can now be viewed and table spaces that do not use automatic
  15. storage can have their containers reconfigured.
  16. DB20000I The RESTORE DATABASE command completed successfully.
  18. SET TABLESPACE CONTAINERS FOR 2 USING ( FILE 'C:\db2_data\userspace1'
  19. 256000 )
  20. DB20000I The SET TABLESPACE CONTAINERS command completed successfully.
  23. 768000 )
  24. DB20000I The SET TABLESPACE CONTAINERS command completed successfully.
  27. 128000 )
  28. DB20000I The SET TABLESPACE CONTAINERS command completed successfully.
  31. 512000 )
  32. DB20000I The SET TABLESPACE CONTAINERS command completed successfully.
  34. SET TABLESPACE CONTAINERS FOR 6 USING ( PATH 'C:\db2_data\testspace' )
  35. DB20000I The SET TABLESPACE CONTAINERS command completed successfully.
  38. SQL1277W A redirected restore operation is being performed. Table space
  39. configuration can now be viewed and table spaces that do not use automatic
  40. storage can have their containers reconfigured.
  41. DB20000I The RESTORE DATABASE command completed successfully.
As you can see, although all the redirects finish successfully, it fails to run the restore db mydb continue

1. The script is generated by db2

2. I manually run the above commands too, got the same problem

3. There are 0~7 tablespace containers, but 0, 1, and 7 are automatic storage tablespace,
Expand|Select|Wrap|Line Numbers
  1. db2 => set tablespace containers for 7 using (file "C:\db2_data\C0000000.LRG" 32)
  2. SQL20319N The SET TABLESPACE CONTAINERS command is not allowed on an
  3. automatic storage table space. SQLSTATE=55061
4. The only thing I changed is the file size in the SET TABLESPACE CONTAINERS command, since I don't have enough space for the tablespace allocated on the original machine, but I do have enough space to hold all the data (the backup file is about 28GB only).

Any suggestion/help is appreciated!
Apr 1 '08 #1
2 8503
I have just had the same problem, but I have finally tracked down the cause.
One of more of the "redirect" commands is using a container name that is already in use, OR a redirect is missing for a tablespace and the original location is still in use.
There is no error message when issuing the redirect and a totally misleading message when you try to "continue", but the file name has already been used.
To find which tablespace is causing the problem, look in the diagnostic log. There should be a message.
The conatiner may be in use by another database. This was the problem I had. The redirect commands were generated by a script, which missed them some tablespaces.
The "continue" will not work if it knows that a container is already in use - it is asking you for a missing redirect command.
I hope this helps.
Oct 6 '10 #2
112 100+
You need to provide path for the automatic storage tablespaces. This the reason why your restore is failing.How will the database figure out where to set automatic storage containers for the tablespace (0, 1, and 7 in youe case)

You will also see mesages related to container failed operation while doing a rollforward continue operation in the db2diag.log file.

ideally your restore command should be like one below
-- assuming that you have sufficient space on D: and that teh drive is present on the server

db2 "RESTORE DATABASE mydb FROM 'C:\' TAKEN AT 20080310154100 on ' D:\' dbpath on 'C:\' INTO mydb REDIRECT WITHOUT ROLLING FORWARD "

Ref: http://publib.boulder.ibm.com/infoce...c/r0001976.htm

Cheers, Vijay
Oct 18 '10 #3

Sign in to post your reply or Sign up for a free account.

Similar topics

by: Spieg | last post by:
I've a program with VB6 working with SQLServer 2000. I have a Central Station with the program runnin with full prvileges and that can perform all the actions on the DB. There are also some...
by: butatista | last post by:
Please help SQL Server 2000 Standard I am trying to restore databases on my server and am unable to get them to restore using the database option. For example, the location of my backup...
by: John Rajendran | last post by:
Hi there, I need to take a backup with the following scanerio in mind: At T1 I take the FULL BACK UP of the database called BACK_1_FULL.BACK in c:\ Then at T2 I would like to take only the...
by: xixi | last post by:
i have been tried to restore a backup image from a remote db2 udb on windows server to a local db2 server, i have mapped the network drive from the remote machine to local, but when i run restore...
by: vhernz | last post by:
Hi, I am new in MSSQL and recently encountered a problem in backing up the database. Here is the scenario 1. There is an schedule backup everyweek which overwrite the backup file everytime...
by: Christian Maslen | last post by:
Hi All, I understand in older versions of DB2/UDB this was not possible. The following article explains how I might do this ...
by: Nasif | last post by:
Hello All I am currently doing a project on MS SQL Server 2005 where I am in need of table level backup/restore. I know about FILEGROUP. But in our project using FILEGROUP is not feasible. As...
by: harshadd | last post by:
http://images.orkut.com/orkut/photos/OgAAAPCx9BDT2K9eZgmdGn5dAG_oKl7hf_SnAM8q4fIPozZ1oOIYdzAwHLfBA1HFlX6F04O5kWMQGYlUiHs7NbwPm10Am1T1UJ6Eoc0OhIb-Tkbf1rcJlIni46gd.jpg Pls see the above error I am...
by: prakash mhatre | last post by:
I want to restore backup from mapped network drive which i have shared in MSSQL server 2003. I have mapped a network drive & given sharing to the folder. I am using a batch file to restore...
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 4 Oct 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
by: tracyyun | last post by:
Hello everyone, I have a question and would like some advice on network connectivity. I have one computer connected to my router via WiFi, but I have two other computers that I want to be able to...
by: giovanniandrean | last post by:
The energy model is structured as follows and uses excel sheets to give input data: 1-Utility.py contains all the functions needed to calculate the variables and other minor things (mentions...
by: NeoPa | last post by:
Hello everyone. I find myself stuck trying to find the VBA way to get Access to create a PDF of the currently-selected (and open) object (Form or Report). I know it can be done by selecting :...
by: NeoPa | last post by:
Introduction For this article I'll be using a very simple database which has Form (clsForm) & Report (clsReport) classes that simply handle making the calling Form invisible until the Form, or all...
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 1 Nov 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM) Please note that the UK and Europe revert to winter time on...
by: nia12 | last post by:
Hi there, I am very new to Access so apologies if any of this is obvious/not clear. I am creating a data collection tool for health care employees to complete. It consists of a number of...
by: isladogs | last post by:
The next online meeting of the Access Europe User Group will be on Wednesday 6 Dec 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). In this month's session, Mike...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.