By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,563 Members | 1,307 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,563 IT Pros & Developers. It's quick & easy.

Cannot load program db2licm

P: n/a
Hi, I have installed DB2 ESE on AIX 5.2. And when I try to execute
db2licm -l I get the following error:

exec(): 0509-036 Cannot load program db2licm because of the following
errors:
0509-130 Symbol resolution failed for db2licm because:
0509-136 Symbol LicCheckDPF (number 68) is not exported from
dependent module /usr/opt/db2_08_01/lib/
libdb2licm.a.
0509-192 Examine .loader section symbols with the
'dump -Tv' command.

Can anybody help me find a solution for this error?
Thanks.
Jan 16 '08 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Eliane wrote:
Hi, I have installed DB2 ESE on AIX 5.2. And when I try to execute
db2licm -l I get the following error:

exec(): 0509-036 Cannot load program db2licm because of the following
errors:
0509-130 Symbol resolution failed for db2licm because:
0509-136 Symbol LicCheckDPF (number 68) is not exported from
dependent module /usr/opt/db2_08_01/lib/
libdb2licm.a.
0509-192 Examine .loader section symbols with the
'dump -Tv' command.

Can anybody help me find a solution for this error?
Thanks.
Did you recently apply a fixpak? Are you running "db2licm" from the
instance (as opposed to the install path of /usr/opt/db2_08_01/adm)? Did
you forget to run db2iupdt on all your instances after applying that
fixpak?

Curious minds want to know. :-)
Jan 16 '08 #2

P: n/a
On 16 jan, 13:56, Darin McBride <dmcbr...@naboo.to.org.no.spam.for.me>
wrote:
Eliane wrote:
Hi, I have installed DB2 ESE on AIX 5.2. And when I try to execute
db2licm -l I get the following error:
exec(): 0509-036 Cannot load program db2licm because of the following
errors:
0509-130 Symbol resolution failed for db2licm because:
0509-136 Symbol LicCheckDPF (number 68) is not exported from
dependent module /usr/opt/db2_08_01/lib/
libdb2licm.a.
0509-192 Examine .loader section symbols with the
'dump -Tv' command.
Can anybody help me find a solution for this error?
Thanks.

Did you recently apply a fixpak? Are you running "db2licm" from the
instance (as opposed to the install path of /usr/opt/db2_08_01/adm)? Did
you forget to run db2iupdt on all your instances after applying that
fixpak?

Curious minds want to know. :-)
Hey, you were right...I forgot to apply a fixpak. It's working now.
Thanks.
Jan 16 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.