By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,007 Members | 1,248 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,007 IT Pros & Developers. It's quick & easy.

Lock Manager Heap

P: n/a
Hi,

I Have problem connect to a database, it takes lot of time connecting.
So i took a snapshot and found out
Memory Pool Type = Lock Manager Heap

Current size (bytes) = 176668672

High water mark (bytes) = 176668672

Configured size (bytes) = 176685056

is there something to do with memory. If so how can I change this.
like many parameters have to e
changed so what is the right way.

Thank you

Nov 5 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
On Nov 6, 12:59 am, bujjus...@gmail.com wrote:
Hi,

I Have problem connect to a database, it takes lot of time connecting.
So i took a snapshot and found out
Memory Pool Type = Lock Manager Heap

Current size (bytes) = 176668672

High water mark (bytes) = 176668672

Configured size (bytes) = 176685056

is there something to do with memory. If so how can I change this.
like many parameters have to e
changed so what is the right way.

Thank you
You can check this parameter at db cfg:

Max storage for lock list (4KB) (LOCKLIST)

Nov 6 '07 #2

P: n/a
Ah Yu (Quentin) wrote:
On Nov 6, 12:59 am, bujjus...@gmail.com wrote:
>Hi,

I Have problem connect to a database, it takes lot of time connecting.
Is this the firstconnection to the database? If so, the delay is probably
due to the database being implicitly activated upon first connect (and
deactivated once the last connection is terminated). You can address this
by explicitly activating the database using the ACTIVATE DB command:

$ db2 ACTIVATE DB <dbname>

During activation, DB2 will allocate various db-specific memory pools and
also create the log files (among other things). Depending on your
configuration, this may take a while.

--
Knut Stolze
DB2 z/OS Utilities Development
IBM Germany
Nov 6 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.