By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,590 Members | 2,174 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,590 IT Pros & Developers. It's quick & easy.

Restore DB problem

P: 2
Hello, guys!

Could anyone suggest me with following problem.
I try to restore DB from 8 version to 9 version. Here is list of my actions:

1. I made offline-backup in 8 version

2. On 9 version I executed:
"DB2 RESTORE DB <MY_DB> FROM <PATH-TO-BACKUP>" INTO <MY-DB> WITH 1 BUFFERS BUFFER 100"
3. My db is restored but with following response:

"SQL2519N ... error code : -1006 ".

Looks like "-1006" corresponds to "SQL1006N", that claims as user response:
"Exit the current application program and return to the operating system. Change the code page for the process and restart the application program"
That's the problem!! I actually don't know how to change the code page for the process....

Can anyone help me with this?
Or maybe I do something wrong?

Thanks in advance
Oct 18 '07 #1
Share this Question
Share on Google+
2 Replies


docdiesel
Expert 100+
P: 297
Hi,

we had a similar problem when staying with v8 but changing the hardware - and the Linux installation. If you're using Linux and are migrating to another system, check the system variable LC_CTYPE on your old and your new system. Maybe you'll need to adjust the new one. Alternatively, you could create a new empty db using the old language setting and then restore into that one.

Regards,

Bernd
Oct 18 '07 #2

P: 2
Thanks!

But looks like I've resolved the problem using code page:

DB2SET DB2CODEPAGE=1252
DB2STOP
DB2START

And after that my db has been migrated successfully
Oct 19 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.