By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,610 Members | 1,697 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,610 IT Pros & Developers. It's quick & easy.

setting pause on output in CLP (Db2 9)

P: n/a
Hi,

I am using db2 9 CLP. When the output of the select command is more
than a page the messages scrolls out of the page. Is it possible to
pause the messages so that they can be viewed one page at a time,
( just like 'set pause on' in Oracle sql prompt). I am unable to find
any command options that correspons to this setting.

Thanks.
Baski.

Aug 10 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Baski wrote:
Hi,

I am using db2 9 CLP. When the output of the select command is more
than a page the messages scrolls out of the page. Is it possible to
pause the messages so that they can be viewed one page at a time,
( just like 'set pause on' in Oracle sql prompt). I am unable to find
any command options that correspons to this setting.

Thanks.
Baski.
Windows:
db2 select * from mytable | more

or

Linux:
db2 select \* from mytable | pg
Jan M. Nelken

Aug 10 '07 #2

P: n/a
Windows:
db2 select * from mytable | more

or

Linux:
db2 select \* from mytable | pg

Jan M. Nelken
Hi Nelken,

It did not work. (on windows)

db2 =select * from ict_dim_time | more
SQL0104N An unexpected token "|" was found following "* from
ict_dim_time".
Expected tokens may include: "<space>". SQLSTATE=42601
db2 =>

any idea???

Thanks.

Aug 10 '07 #3

P: n/a
Baski wrote:
>Windows:
db2 select * from mytable | more

or

Linux:
db2 select \* from mytable | pg

Jan M. Nelken

Hi Nelken,

It did not work. (on windows)

db2 =select * from ict_dim_time | more
SQL0104N An unexpected token "|" was found following "* from
ict_dim_time".
Expected tokens may include: "<space>". SQLSTATE=42601
db2 =>

any idea???

Thanks.
db2 "select * from ict_dim_time" | more

--
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
| In A World Without Fences Who Needs Gates? |
| Experience Linux. |
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Aug 10 '07 #4

P: n/a
On Aug 10, 1:25 pm, Gregor Kova <gregor.ko...@mikropis.siwrote:
Baski wrote:
Windows:
db2 select * from mytable | more
or
Linux:
db2 select \* from mytable | pg
Jan M. Nelken
Hi Nelken,
It did not work. (on windows)
db2 =select * from ict_dim_time | more
SQL0104N An unexpected token "|" was found following "* from
ict_dim_time".
Expected tokens may include: "<space>". SQLSTATE=42601
db2 =>
any idea???
Thanks.

db2 "select * from ict_dim_time" | more

--
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
| In A World Without Fences Who Needs Gates? |
| Experience Linux. |
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-- Hide quoted text -

- Show quoted text -
Thanks it worked, actually I was trying | more in 'db2 =>' prompt
rather than at the OS prompt. That was the problem.
Any Idea abt doing the same thing in db2=prompt.

Aug 10 '07 #5

P: n/a
Baski wrote:
Thanks it worked, actually I was trying | more in 'db2 =>' prompt
rather than at the OS prompt. That was the problem.
Any Idea abt doing the same thing in db2=prompt.
There is no option for it. No hidden feature....

Cheers
Serge
--
Serge Rielau
DB2 Solutions Development
IBM Toronto Lab
Aug 10 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.