By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,756 Members | 1,745 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,756 IT Pros & Developers. It's quick & easy.

Unicode...

P: n/a
DB2 UDB 8.2 / AIX 5.3

I had asked a few questions previously about this and did not receive
any response. Are there any unicode users out there that might know
the answers to these two questions:

1) Is it necessary to use the SQLConnectW() (CLI APIs) to connect to
the database?

I am prototyping a change where we are changing a set of existing
tables from ASCII to Unicode. I am able to run ok using the regular
connect. I do not see any issues with the CHAR and VARCHAR fields in
the table. I turned on Japanese locale settings on the machine and
had a coworker insert some characters in those fields...it seems to
display ok. I believe Japanese uses 2-byte characters so if there was
an issue I would think it would but garbage in those columns.

When I originally set up the test I didnt see anything that referred
to using SQLConnectW in the DB2 information I was reading. I ran
across it several days later while researching some other questions I
had and was worried I might be missing something.

Does anyone know if SQLConnectW is only used in certain instances or
if I am going to have issues later on for not using it?

2) Do I need to change the DB2CODEPAGE to 1208 (or something that
supports all utf-8?

Again, it did not specify to do this in the write ups I found but I
also read some information about setting the code pages. Also, as I
said above, my prototype is working and I have not changed it from the
default English (though I tried and someone here was nice enough to
tell me that you cannot change it once it is setup).

So..question #2 is it necessary to change the CODEPAGE?
Thanks in advance!

Aug 7 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.