By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,226 Members | 1,027 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,226 IT Pros & Developers. It's quick & easy.

Uses need to be administrators with Windows Server 2003

P: n/a
Hello,

On a Windows Server 2003 (Release 2, service pack 1), I've installed the
latest DB2 Connect, i.e. only client software/drivers.

I cannot make tools like the Command Line Processor and the Command
Editor work for people unless I put add them to the Administrators group.

During installation, I'm asked if I want to use Operating System Security
(or something like that). I've tried installing with this option set to
both yes and no, but it doesn't seem to make a difference. When I click
yes, it's not even enough to add the users to the DB2ADMNS group.

Symptom, when the user isn't member of Administrators:

1. When starting the CLP, nothing happens; the user is simply left in a
normal "DOS-box", instead of being greeted with the wanted "(c) Copyright
IBM Corporation 1993,2002 Command Line Processor for DB2 ADCL 9.1.2
[...]" message.

2. When starting the Command Editor and using the "Add..." button (and
entering credentials), I get a strange "SQL1042C An unexpected system
error occurred." (sqlcode -1042; sqlstate 58004). (Again: Things work
well if I do the same thing after having added the user to the
Administrators group).

It doesn't seem to make a difference whether the user is a local machine
user or a domain user.

The same problem doesn't seem to exist with Windows XP.

A bit of googling made me play with the DB2TEMPDIR environment (or DB2
registry) variable. At one point, this made CLP work, but no the Command
Editor. And unfortunately, I haven't been able to reproduce this --
somewhat improved -- situation after subsequent re-installations of DB2
Connect.

Any ideas?

--
Regards,
Troels Arvin <tr****@arvin.dk>
http://troels.arvin.dk/
Mar 13 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.