By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,225 Members | 1,051 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,225 IT Pros & Developers. It's quick & easy.

STMM 9.1warning message

P: n/a
I have the following warning message in my db2diag file:

2007-02-22-10.59.20.426000-300 I624712H529 LEVEL: Warning
PID : 1012 TID : 4332 PROC : db2syscs.exe
INSTANCE: DB2 NODE : 000 DB : FLINT
APPHDL : 0-19 APPID: GA1403A2.P388.070222155919
AUTHID : FLINT
FUNCTION: DB2 UDB, Self tuning memory manager,
stmmStartSortDbMonitorIfNecessary, probe:1465
MESSAGE : STMM Sort Memory Tuning cannot be activated because the
Database
Manager Configuration Parameter SHEAPTHRES is not set to 0.

However, I can't set SHEAPTHRES to 0 as requested because it's not
within the valid range of values.
How do I correct this?

Feb 22 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
dunleav1 wrote:
I have the following warning message in my db2diag file:

2007-02-22-10.59.20.426000-300 I624712H529 LEVEL: Warning
PID : 1012 TID : 4332 PROC : db2syscs.exe
INSTANCE: DB2 NODE : 000 DB : FLINT
APPHDL : 0-19 APPID: GA1403A2.P388.070222155919
AUTHID : FLINT
FUNCTION: DB2 UDB, Self tuning memory manager,
stmmStartSortDbMonitorIfNecessary, probe:1465
MESSAGE : STMM Sort Memory Tuning cannot be activated because the
Database
Manager Configuration Parameter SHEAPTHRES is not set to 0.

However, I can't set SHEAPTHRES to 0 as requested because it's not
within the valid range of values.
How do I correct this?
No, 0 is valid:
http://publib.boulder.ibm.com/infoce...c/r0000260.htm

--
Knut Stolze
DB2 z/OS Utilities Development
IBM Germany
Feb 22 '07 #2

P: n/a
Yes, the documentation states I set the value to 0 but db2cc does not
let me.
It's a db2cc bug. The gui will not let me set the value below 250.

I had to set the value using db2 update dbm config sheapthres=0
deferred.
Then stop and start the instance.

Feb 23 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.