467,136 Members | 1,414 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,136 developers. It's quick & easy.

Media Error - while restoring backup from Tape

Hi All,

We are trying to restore a backup that we took last night on a fresh
new Tape. The backup was successful but the restore is failing with the
following error:

db2 =restore db gpiecuk from /dev/rmt0
SQL0980C A disk error occurred. Subsequent SQL statements cannot be
processed. SQLSTATE=58005

Looking into Db2diag, we found the following error:

2007-01-11-18.41.07.500528+000 I156060C339 LEVEL: Error
PID : 41792 TID : 1 PROC : db2med.47288.0
0
INSTANCE: abcde NODE : 000
FUNCTION: DB2 UDB, database utilities, sqluReadFromFileDevice, probe:90
DATA #1 : Hexdump, 4 bytes
0x2FF21250 : 860F 0003 ....

2007-01-11-18.41.07.500883+000 I156400C339 LEVEL: Warning
PID : 41792 TID : 1 PROC : db2med.47288.0
0
INSTANCE: abcde NODE : 000
FUNCTION: DB2 UDB, database utilities, sqluMCReadMediaHeaderFromDevice,
probe:80
MESSAGE : Media controller -- Problem reading header from device:
0x860f0003

The message seems to be clear that the HEADER is missing from the Tape.
How to resolve this issue.

The backup was taken on a database on TEST Server which is on db2v7.2.
We are trying to restore it to database in DEV Box which is at Db2v8.2.
The command used to take backup was :
db2 backup database dbname to /dev/rmt0

Platform is AIX.

Regards,
Divakar

Jan 11 '07 #1
  • viewed: 3705
Share:
2 Replies
Did it fail as the restore started? if so verify that the userid running
the restore has read access to the tape device.

Phil Sherman

Divakar wrote:
Hi All,

We are trying to restore a backup that we took last night on a fresh
new Tape. The backup was successful but the restore is failing with the
following error:

db2 =restore db gpiecuk from /dev/rmt0
SQL0980C A disk error occurred. Subsequent SQL statements cannot be
processed. SQLSTATE=58005

Looking into Db2diag, we found the following error:

2007-01-11-18.41.07.500528+000 I156060C339 LEVEL: Error
PID : 41792 TID : 1 PROC : db2med.47288.0
0
INSTANCE: abcde NODE : 000
FUNCTION: DB2 UDB, database utilities, sqluReadFromFileDevice, probe:90
DATA #1 : Hexdump, 4 bytes
0x2FF21250 : 860F 0003 ....

2007-01-11-18.41.07.500883+000 I156400C339 LEVEL: Warning
PID : 41792 TID : 1 PROC : db2med.47288.0
0
INSTANCE: abcde NODE : 000
FUNCTION: DB2 UDB, database utilities, sqluMCReadMediaHeaderFromDevice,
probe:80
MESSAGE : Media controller -- Problem reading header from device:
0x860f0003

The message seems to be clear that the HEADER is missing from the Tape.
How to resolve this issue.

The backup was taken on a database on TEST Server which is on db2v7.2.
We are trying to restore it to database in DEV Box which is at Db2v8.2.
The command used to take backup was :
db2 backup database dbname to /dev/rmt0

Platform is AIX.

Regards,
Divakar
Jan 11 '07 #2
I got the error while doing the restore.

The userid used to do the backup and then restore were the same.

Do you think we need to do something like formating the tape before
using it.

Divakar

Jan 12 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Mirko Slavko | last post: by
2 posts views Thread by Chirath Fernando | last post: by
2 posts views Thread by Kev | last post: by
9 posts views Thread by Stanley Sinclair | last post: by
5 posts views Thread by David | last post: by
reply views Thread by Hemant Shah | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.