469,578 Members | 1,210 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,578 developers. It's quick & easy.

Error Help: CLI0120E Memory Allocation Failure

Error Help: CLI0120E Memory Allocation Failure
--------------------------------------------------------------------------------

Hi

Any help would really be appreciated. I am getting the following error in my VB program.

[IBM][CLI Driver] CLI0120E Memory Allocation Failure SQLSTATE=S1001

Any help on what could possibly cause this kind of error would be greatly appreciated.

Thanks in advance.
Nov 30 '06 #1
4 3319
r035198x
13,262 8TB
Error Help: CLI0120E Memory Allocation Failure
--------------------------------------------------------------------------------

Hi

Any help would really be appreciated. I am getting the following error in my VB program.

[IBM][CLI Driver] CLI0120E Memory Allocation Failure SQLSTATE=S1001

Any help on what could possibly cause this kind of error would be greatly appreciated.

Thanks in advance.
Make sure your database is started because the main cause is that the application has failed to connect to the database.
Also maybe check if BULK mode is on, if so, try using the normal mode.
Dec 1 '06 #2
Make sure your database is started because the main cause is that the application has failed to connect to the database.
Also maybe check if BULK mode is on, if so, try using the normal mode.
Hi

Thanks for response. It is definitely connected as it is extracting data. After a while the error pops up. I have increased the memory on the server ten fold, it diddnt resolve it. The task manager confirms that the application is not using all of the memory. This program worked perfectly up untill we upgraded to DB2 version 8. Could it be that ?

Again thanks for response
Dec 6 '06 #3
r035198x
13,262 8TB
Hi

Thanks for response. It is definitely connected as it is extracting data. After a while the error pops up. I have increased the memory on the server ten fold, it diddnt resolve it. The task manager confirms that the application is not using all of the memory. This program worked perfectly up untill we upgraded to DB2 version 8. Could it be that ?

Again thanks for response
For some reason then the connection is getting lost at times. I do not think it has anything to do with the memory though. Upgrade to DB2 certainly comes with some side effects at times (from my experince.) Maybe you should try uninstalling and installing a fresh copy od DB2 altogether.
Dec 6 '06 #4
For some reason then the connection is getting lost at times. I do not think it has anything to do with the memory though. Upgrade to DB2 certainly comes with some side effects at times (from my experince.) Maybe you should try uninstalling and installing a fresh copy od DB2 altogether.
Hi

Before I re-install DB2 could it be that the McAfee antivirus could be the cause
of this. I am getting the feeling that something is causing the connection or program to time out. Although I have changed the connection to time out only after 60 min. What else could be causing a delay in transmission.

Thanks again.
Dec 8 '06 #5

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

7 posts views Thread by kk | last post: by
4 posts views Thread by kk | last post: by
16 posts views Thread by Jacob | last post: by
2 posts views Thread by mghale | last post: by
3 posts views Thread by Hassan Iqbal | last post: by
66 posts views Thread by Johan Tibell | last post: by
reply views Thread by suresh191 | last post: by
4 posts views Thread by guiromero | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.