By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,584 Members | 1,803 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,584 IT Pros & Developers. It's quick & easy.

db2admin server doesn't start, SQL1042C on AIX

P: n/a
KPA
Hi,

After installation of a new maintenancelevel on aix (5.3, ML 05) db2
administration server doesn't start anymore.

After starting I get the error: SQL1042C An unexpected system error
occurred.

Did anyone encounter the same problem and knows how to solve this?

We ar running db2V8 Fixpak 13.

Greetings
Oct 19 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
KPA wrote:
After installation of a new maintenancelevel on aix (5.3, ML 05) db2
administration server doesn't start anymore.

After starting I get the error: SQL1042C An unexpected system error
occurred.
The PC version can be repaired "db2admin drop" and then "db2admin create".

But I remember that the AIX version behaves different and Knut posted a
solution here some month ago.

Bernd

--
What do you get when you cross a mail pigeon with a parrot ? Voice mail
Oct 19 '06 #2

P: n/a
KPA wrote:
Hi,

After installation of a new maintenancelevel on aix (5.3, ML 05) db2
administration server doesn't start anymore.

After starting I get the error: SQL1042C An unexpected system error
occurred.

Did anyone encounter the same problem and knows how to solve this?

We ar running db2V8 Fixpak 13.
We had this problem recently as well, on AIX 5.3 with DB2 8.1 FP10.
Seems that TL05 with SP1 or SP2 has a problem (IY89861) and DB2 is
affected in some userauth functions.

We were getting SQL1092 errors during dascrt steps, and later the
db2adm user could not start the AdminServer (SQL1042).

After applying the efix for IY89861 on top of TL05-SP2, things are
now working correctly again.
HTH, Eric
Oct 23 '06 #3

P: n/a
KPA
Thanks Eric.

We received the efix from IBM and things are working fine now

Greetings

"Eric.Jones" <Er********@hispeed.chwrote in message
news:a9***************************@news.hispeed.ch ...
KPA wrote:
>Hi,

After installation of a new maintenancelevel on aix (5.3, ML 05) db2
administration server doesn't start anymore.

After starting I get the error: SQL1042C An unexpected system error
occurred.

Did anyone encounter the same problem and knows how to solve this?

We ar running db2V8 Fixpak 13.

We had this problem recently as well, on AIX 5.3 with DB2 8.1 FP10.
Seems that TL05 with SP1 or SP2 has a problem (IY89861) and DB2 is
affected in some userauth functions.

We were getting SQL1092 errors during dascrt steps, and later the
db2adm user could not start the AdminServer (SQL1042).

After applying the efix for IY89861 on top of TL05-SP2, things are
now working correctly again.
HTH, Eric

Oct 27 '06 #4

P: n/a
KPA
Hi Bernd,

The db2admin drop and create was the first thing I tried, but it didn't
solve the problem.
An efix from IBM on AIX did.

Thanks anyway
"Bernd Hohmann" <ho*****@harddiskcafe.dewrote in message
news:4p************@individual.net...
KPA wrote:
>After installation of a new maintenancelevel on aix (5.3, ML 05) db2
administration server doesn't start anymore.

After starting I get the error: SQL1042C An unexpected system error
occurred.

The PC version can be repaired "db2admin drop" and then "db2admin create".

But I remember that the AIX version behaves different and Knut posted a
solution here some month ago.

Bernd

--
What do you get when you cross a mail pigeon with a parrot ? Voice mail

Oct 27 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.