By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,236 Members | 1,453 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,236 IT Pros & Developers. It's quick & easy.

SQL1326N The file or directory cannot be accessed

P: n/a
Hello,

using 9.1 I'm trying to create a database in the instance 'bruno' but
receive following error code :

SQL1326N *The file or directory "/home/bruno/" cannot be accessed

Platform is Linux and I tried :
chmod 777 /home/bruno
chmod -R 777 /home/bruno/sqllib/

but without success.
Thanks for any clue.

Bye,
Bruno

Oct 9 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Ian
Bruno Costacurta wrote:
Hello,

using 9.1 I'm trying to create a database in the instance 'bruno' but
receive following error code :

SQL1326N The file or directory "/home/bruno/" cannot be accessed
It would be helpful if you gave the actual command that you tried.
Platform is Linux and I tried :
chmod 777 /home/bruno
chmod -R 777 /home/bruno/sqllib/

but without success.

Certainly without success. That also hosed your instance by messing up
all of the permissions. To fix, stop any processes running as bruno,
and then, as root, you can run 'db2iupdt bruno' (db2iupdt is in the
<install>/instance directory).
Then post the create database command you ran again.

Oct 9 '06 #2

P: n/a
Ian wrote:
Bruno Costacurta wrote:
>Hello,

using 9.1 I'm trying to create a database in the instance 'bruno' but
receive following error code :

SQL1326N The file or directory "/home/bruno/" cannot be accessed

It would be helpful if you gave the actual command that you tried.
>Platform is Linux and I tried :
chmod 777 /home/bruno
chmod -R 777 /home/bruno/sqllib/

but without success.


Certainly without success. That also hosed your instance by messing up
all of the permissions. To fix, stop any processes running as bruno,
and then, as root, you can run 'db2iupdt bruno' (db2iupdt is in the
<install>/instance directory).
Then post the create database command you ran again.
I solved this by creating a new user and a related instance.
I suppose this design is better.

Bye,
Bruno

Oct 10 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.