By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,743 Members | 1,072 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,743 IT Pros & Developers. It's quick & easy.

Regarding Replication DB2 UDB

P: n/a
sat
i have seen the check status then it is showing like :

Type Of Thread Status
HoldL Resting
Admin Thread Resting
Worker Thread Resting

So now how can i activate them again?

Knut Stolze wrote:
sat wrote:
Hi!
I have seen jus now in the target table (TGDEPTCOPY) it's still
showing only 4 records.I kept the time interval for replication as 15
minutes.But still its not working.I'm not even facing any errors.Please
do let me know what might be the problem.

Hard to tell. Did you use the logs when you started capture and apply?
Have you actually started both? What do the logs show? What does
the "status" in the Replication Center show?

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #1
Share this Question
Share on Google+
15 Replies


P: n/a
sat wrote:
i have seen the check status then it is showing like :

Type Of Thread Status
HoldL Resting
Admin Thread Resting
Worker Thread Resting

So now how can i activate them again?
Is that the status of capture or apply? Have you started both? What was
the message you got upon starting of each?

How about the logs - which entries do you find there? Did you use the logs
when you started capture and apply?

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #2

P: n/a
sat
The status below is for apply and first itself i have started both the
capture and apply programs.And then what i did is like while defining
the subscription set in the ROW FILTER i have given only ENO which are
>= E00 should be applied.And after that i inserted 2 records which are E22 , E23 and recently ( means today morning) i added one more row E25...but they are not being copied.

Knut Stolze wrote:
sat wrote:
i have seen the check status then it is showing like :

Type Of Thread Status
HoldL Resting
Admin Thread Resting
Worker Thread Resting

So now how can i activate them again?

Is that the status of capture or apply? Have you started both? What was
the message you got upon starting of each?

How about the logs - which entries do you find there? Did you use the logs
when you started capture and apply?

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #3

P: n/a
sat wrote:
The status below is for apply and first itself i have started both the
capture and apply programs.And then what i did is like while defining
the subscription set in the ROW FILTER i have given only ENO which are
= E00 should be applied.And after that i inserted 2 records which are E22
, E23 and recently ( means today morning) i added one more row E25...but
they are not being copied.
Again, what do you see in the logs?

Since you are using row filter, what happens if you omit the filter?

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #4

P: n/a
sat
If i omit the row filter then by default all the rows will be
copied.Now as i have given only ENO's >= E00 will be copied.Hope i'm
right.

i didnt get the Question what u're trying to ask about logs.
If u can please elaborate the Question and let me know.

Knut Stolze wrote:
sat wrote:
The status below is for apply and first itself i have started both the
capture and apply programs.And then what i did is like while defining
the subscription set in the ROW FILTER i have given only ENO which are
>= E00 should be applied.And after that i inserted 2 records which are E22
, E23 and recently ( means today morning) i added one more row E25...but
they are not being copied.

Again, what do you see in the logs?

Since you are using row filter, what happens if you omit the filter?

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #5

P: n/a
sat
2006-09-15-21.08.10.031000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.
2006-09-15-21.09.10.421000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "0" minutes
and "59" seconds.
2006-09-15-21.10.09.718000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.

2006-09-16-15.00.19.062000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "HoldLThread".

2006-09-16-15.00.19.281000 <queryDB2StatusASN0552E "Apply" :
"DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "sqlmonss". The table name
is "N/A". The SQLCODE is "-30082". The SQLSTATE is "08001". The
SQLERRMC is "24˙USERNAME AND/OR PASSWORD INVALID˙". The SQLERRP is
"SQLEXPLG".

2006-09-16-15.00.19.281000 SQL30082 "Apply" : "DEPTQUAL" : "Initial" :
Attempt to establish connection failed with security reason "24"

("USERNAME AND/OR PASSWORD INVALID"). SQLSTATE=08001
2006-09-16-15.00.19.281000 <Asnenv:delEnvIpcQRcvHdlASN8008D "Apply"
: "DEPTQUAL" : "Initial" : "Destroyed" IPC queue with key(s)
"(OSSEIPC48tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC49tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC50tempDB2.COPYDB.DEPTQUAL.APP.IPC)".

2006-09-16-15.00.19.281000 <_asnApplyASN1097I APPLY "DEPTQUAL" :
"Initial". The Apply program stopped.

2006-09-16-15.00.19.328000 <disconnectDB2DistributedASN0552E "Apply"
: "DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "DISCONNECT". The table
name is "N/A". The SQLCODE is "-1024". The SQLSTATE is "08003". The
SQLERRMC is "". The SQLERRP is "SQLACALL".

2006-09-19-15.13.29.531000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "HoldLThread".

2006-09-19-15.13.29.531000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "AdminThread".

2006-09-19-15.13.29.531000 <queryDB2StatusASN0552E "Apply" :
"DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "sqlmonss". The table name
is "N/A". The SQLCODE is "-30082". The SQLSTATE is "08001". The
SQLERRMC is "24˙USERNAME AND/OR PASSWORD INVALID˙". The SQLERRP is
"SQLEXPLG".
These were some of the errors i have see.....

sat wrote:
If i omit the row filter then by default all the rows will be
copied.Now as i have given only ENO's >= E00 will be copied.Hope i'm
right.

i didnt get the Question what u're trying to ask about logs.
If u can please elaborate the Question and let me know.

Knut Stolze wrote:
sat wrote:
The status below is for apply and first itself i have started both the
capture and apply programs.And then what i did is like while defining
the subscription set in the ROW FILTER i have given only ENO which are
= E00 should be applied.And after that i inserted 2 records which are E22
, E23 and recently ( means today morning) i added one more row E25....but
they are not being copied.
Again, what do you see in the logs?

Since you are using row filter, what happens if you omit the filter?

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #6

P: n/a
sat
Can u please tell me what i need to do if i want to bring the the
status of the capture program from the resting status to the active
state.And just now i have observed that its showint like the status as
PRESUMED DOWN for apply program.
So, please guide me regarding this.

sat wrote:
2006-09-15-21.08.10.031000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.
2006-09-15-21.09.10.421000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "0" minutes
and "59" seconds.
2006-09-15-21.10.09.718000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.

2006-09-16-15.00.19.062000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "HoldLThread".

2006-09-16-15.00.19.281000 <queryDB2StatusASN0552E "Apply" :
"DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "sqlmonss". The table name
is "N/A". The SQLCODE is "-30082". The SQLSTATE is "08001". The
SQLERRMC is "24˙USERNAME AND/OR PASSWORD INVALID˙". The SQLERRP is
"SQLEXPLG".

2006-09-16-15.00.19.281000 SQL30082 "Apply" : "DEPTQUAL" : "Initial" :
Attempt to establish connection failed with security reason "24"

("USERNAME AND/OR PASSWORD INVALID"). SQLSTATE=08001
2006-09-16-15.00.19.281000 <Asnenv:delEnvIpcQRcvHdlASN8008D "Apply"
: "DEPTQUAL" : "Initial" : "Destroyed" IPC queue with key(s)
"(OSSEIPC48tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC49tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC50tempDB2.COPYDB.DEPTQUAL.APP.IPC)".

2006-09-16-15.00.19.281000 <_asnApplyASN1097I APPLY "DEPTQUAL" :
"Initial". The Apply program stopped.

2006-09-16-15.00.19.328000 <disconnectDB2DistributedASN0552E "Apply"
: "DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "DISCONNECT". The table
name is "N/A". The SQLCODE is "-1024". The SQLSTATE is "08003". The
SQLERRMC is "". The SQLERRP is "SQLACALL".

2006-09-19-15.13.29.531000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "HoldLThread".

2006-09-19-15.13.29.531000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "AdminThread".

2006-09-19-15.13.29.531000 <queryDB2StatusASN0552E "Apply" :
"DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "sqlmonss". The table name
is "N/A". The SQLCODE is "-30082". The SQLSTATE is "08001". The
SQLERRMC is "24˙USERNAME AND/OR PASSWORD INVALID˙". The SQLERRP is
"SQLEXPLG".
These were some of the errors i have see.....

sat wrote:
If i omit the row filter then by default all the rows will be
copied.Now as i have given only ENO's >= E00 will be copied.Hope i'm
right.

i didnt get the Question what u're trying to ask about logs.
If u can please elaborate the Question and let me know.

Knut Stolze wrote:
sat wrote:
>
The status below is for apply and first itself i have started both the
capture and apply programs.And then what i did is like while defining
the subscription set in the ROW FILTER i have given only ENO which are
>= E00 should be applied.And after that i inserted 2 records which are E22
, E23 and recently ( means today morning) i added one more row E25....but
they are not being copied.
>
Again, what do you see in the logs?
>
Since you are using row filter, what happens if you omit the filter?
>
--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #7

P: n/a
sat wrote:
Can u please tell me what i need to do if i want to bring the the
status of the capture program from the resting status to the active
state.
Is the "Resting" the status of Apply or Capture? Here you talk about
Capture, but in the other posting you said it's the Apply status.
And just now i have observed that its showint like the status as
PRESUMED DOWN for apply program.
So, please guide me regarding this.
I'm pretty sure that it comes down to figuring out what causes the error
messages below and then fixing those problems.
sat wrote:
>2006-09-15-21.08.10.031000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.
2006-09-15-21.09.10.421000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "0" minutes
and "59" seconds.
2006-09-15-21.10.09.718000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.

2006-09-16-15.00.19.062000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "HoldLThread".

2006-09-16-15.00.19.281000 <queryDB2StatusASN0552E "Apply" :
"DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "sqlmonss". The table name
is "N/A". The SQLCODE is "-30082". The SQLSTATE is "08001". The
SQLERRMC is "24ĆæUSERNAME AND/OR PASSWORD INVALIDĆæ". The SQLERRP is
"SQLEXPLG".
Check the user/password settings that you use in the Control Center
(or "asnclp" if you manage DB2 Replication that way). I'd think that you
have somewhere a non-existing user or an invalid password specified, which
causes the SQL30082 to be raised. Also, make sure that the user under
whose authority capture/apply is run is allowed to connect to both
databases.
>2006-09-16-15.00.19.281000 <Asnenv:delEnvIpcQRcvHdlASN8008D "Apply"
: "DEPTQUAL" : "Initial" : "Destroyed" IPC queue with key(s)
"(OSSEIPC48tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC49tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC50tempDB2.COPYDB.DEPTQUAL.APP.IPC)".

2006-09-16-15.00.19.281000 <_asnApplyASN1097I APPLY "DEPTQUAL" :
"Initial". The Apply program stopped.

2006-09-16-15.00.19.328000 <disconnectDB2DistributedASN0552E "Apply"
: "DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "DISCONNECT". The table
name is "N/A". The SQLCODE is "-1024". The SQLSTATE is "08003". The
SQLERRMC is "". The SQLERRP is "SQLACALL".
That appears to be a follow-up for the above error. Apply can't connect to
the "COPYDB" (because of invalid credentials) and then shuts down. The
DISCONNECT fails with SQL1024 because the preceeding connect never worked.
So that's actually ok.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 19 '06 #8

P: n/a
sat
Actually for both the capture and apply programs the check status is in
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.

Knut Stolze wrote:
sat wrote:
Can u please tell me what i need to do if i want to bring the the
status of the capture program from the resting status to the active
state.

Is the "Resting" the status of Apply or Capture? Here you talk about
Capture, but in the other posting you said it's the Apply status.
And just now i have observed that its showint like the status as
PRESUMED DOWN for apply program.
So, please guide me regarding this.

I'm pretty sure that it comes down to figuring out what causes the error
messages below and then fixing those problems.
sat wrote:
2006-09-15-21.08.10.031000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.
2006-09-15-21.09.10.421000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "0" minutes
and "59" seconds.
2006-09-15-21.10.09.718000 <CPREST(01/00)ASN1044I APPLY "DEPTQUAL" :
"WorkerThread". The Apply program will become inactive for "1" minutes
and "0" seconds.

2006-09-16-15.00.19.062000 <asnThread::stopASN8045D "Apply" :
"DEPTQUAL" : "Initial" : Thread "Initial" received return code "2011"
from exiting thread "HoldLThread".

2006-09-16-15.00.19.281000 <queryDB2StatusASN0552E "Apply" :
"DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "sqlmonss". The table name
is "N/A". The SQLCODE is "-30082". The SQLSTATE is "08001". The
SQLERRMC is "24˙USERNAME AND/OR PASSWORD INVALID˙". The SQLERRP is
"SQLEXPLG".

Check the user/password settings that you use in the Control Center
(or "asnclp" if you manage DB2 Replication that way). I'd think that you
have somewhere a non-existing user or an invalid password specified, which
causes the SQL30082 to be raised. Also, make sure that the user under
whose authority capture/apply is run is allowed to connect to both
databases.
2006-09-16-15.00.19.281000 <Asnenv:delEnvIpcQRcvHdlASN8008D "Apply"
: "DEPTQUAL" : "Initial" : "Destroyed" IPC queue with key(s)
"(OSSEIPC48tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC49tempDB2.COPYDB.DEPTQUAL.APP.IPC,
OSSEIPC50tempDB2.COPYDB.DEPTQUAL.APP.IPC)".

2006-09-16-15.00.19.281000 <_asnApplyASN1097I APPLY "DEPTQUAL" :
"Initial". The Apply program stopped.

2006-09-16-15.00.19.328000 <disconnectDB2DistributedASN0552E "Apply"
: "DEPTQUAL" : "Initial" : The program encountered an SQL error. The
server name is "COPYDB". The SQL request is "DISCONNECT". The table
name is "N/A". The SQLCODE is "-1024". The SQLSTATE is "08003". The
SQLERRMC is "". The SQLERRP is "SQLACALL".

That appears to be a follow-up for the above error. Apply can't connect to
the "COPYDB" (because of invalid credentials) and then shuts down. The
DISCONNECT fails with SQL1024 because the preceeding connect never worked.
So that's actually ok.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 20 '06 #9

P: n/a
sat wrote:
Actually for both the capture and apply programs the check status is in
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.
I'm sorry, but I don't see any point in continuing this discussion since you
don't appear to read my responses.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 20 '06 #10

P: n/a
sat
Sorry i dint mean that i didnt read your messages.
But this is for the 1st time i'm working on replication so i couldnt
get from ur points.

Knut Stolze wrote:
sat wrote:
Actually for both the capture and apply programs the check status is in
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.

I'm sorry, but I don't see any point in continuing this discussion since you
don't appear to read my responses.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 20 '06 #11

P: n/a
sat
I have given the correct userid and password.Even now i was trying.But
its not working.

2006-09-20-13.20.51.019000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

This is wat i have seen in the capture log today .

Knut Stolze wrote:
sat wrote:
Actually for both the capture and apply programs the check status is in
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.

I'm sorry, but I don't see any point in continuing this discussion since you
don't appear to read my responses.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 20 '06 #12

P: n/a
sat
Check the user/password settings that you use in the Control Center
(or "asnclp" if you manage DB2 Replication that way). I'd think that
you
have somewhere a non-existing user or an invalid password specified,
which
causes the SQL30082 to be raised. Also, make sure that the user under
whose authority capture/apply is run is allowed to connect to both
databases.

Even i have seen in the replication center--Manage passwords and
connectivity--the userid and the password are same.
There is no non-existing user.Because each and every time i'm the only
person gettting connected.
I only created both the capture and apply databases.So,automatically
i'll be able to connect to both the databases.
Even then i'm not able to do.Please do suggest me.

sat wrote:
I have given the correct userid and password.Even now i was trying.But
its not working.

2006-09-20-13.20.51.019000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

This is wat i have seen in the capture log today .

Knut Stolze wrote:
sat wrote:
Actually for both the capture and apply programs the check status is in
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.
I'm sorry, but I don't see any point in continuing this discussion since you
don't appear to read my responses.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Sep 20 '06 #13

P: n/a
sat schrieb:
Check the user/password settings that you use in the Control Center
(or "asnclp" if you manage DB2 Replication that way). I'd think that
you
have somewhere a non-existing user or an invalid password specified,
which
causes the SQL30082 to be raised. Also, make sure that the user under
whose authority capture/apply is run is allowed to connect to both
databases.

Even i have seen in the replication center--Manage passwords and
connectivity--the userid and the password are same.
There is no non-existing user.Because each and every time i'm the only
person gettting connected.
I only created both the capture and apply databases.So,automatically
i'll be able to connect to both the databases.
Even then i'm not able to do.Please do suggest me.

sat wrote:
>I have given the correct userid and password.Even now i was trying.But
its not working.

2006-09-20-13.20.51.019000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

This is wat i have seen in the capture log today .

Knut Stolze wrote:
>>sat wrote:

Actually for both the capture and apply programs the check status is in
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.
I'm sorry, but I don't see any point in continuing this discussion since you
don't appear to read my responses.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Hi,

I think you have to forget to create a password file with asnpwd,
and than start the control server:

asnapply CONTROL_SERVER=xxx APPLY_QUAL=xxx APPLY_PATH="/db2/xxx/db2d
ump" PWDFILE=../../db2xx/replication/asnpwd.aut

Best regards,
Joachim Müller
Sep 21 '06 #14

P: n/a
sat schrieb:
Check the user/password settings that you use in the Control Center
(or "asnclp" if you manage DB2 Replication that way). I'd think that
you
have somewhere a non-existing user or an invalid password specified,
which
causes the SQL30082 to be raised. Also, make sure that the user under
whose authority capture/apply is run is allowed to connect to both
databases.

Even i have seen in the replication center--Manage passwords and
connectivity--the userid and the password are same.
There is no non-existing user.Because each and every time i'm the only
person gettting connected.
I only created both the capture and apply databases.So,automatically
i'll be able to connect to both the databases.
Even then i'm not able to do.Please do suggest me.

sat wrote:
>I have given the correct userid and password.Even now i was trying.But
its not working.

2006-09-20-13.20.51.019000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

This is wat i have seen in the capture log today .

Knut Stolze wrote:
>>sat wrote:

Actually for both the capture and apply programs the check status is in
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.
I'm sorry, but I don't see any point in continuing this discussion since you
don't appear to read my responses.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Hi,

I think you have to forget to create a password file with asnpwd,
and than start the control server:

asnapply CONTROL_SERVER=xxx APPLY_QUAL=xxx APPLY_PATH="/db2/xxx/db2d
ump" PWDFILE=../../db2xx/replication/asnpwd.aut

Best regards,
Joachim Müller
Sep 21 '06 #15

P: n/a
sat
Hi,
I really feel thankful for your timely help.And yesterday i found
out that we need to have PRIMARY KEY on the TARGET TABLE if we need to
create a replication environment.So that was the mistake i have
done.And even i have created the "asnpwd".
Hope i will be getting much encouragement regarding replication.

Thanks & Regards,
Sat.
Joachim Müller wrote:
sat schrieb:
Check the user/password settings that you use in the Control Center
(or "asnclp" if you manage DB2 Replication that way). I'd think that
you
have somewhere a non-existing user or an invalid password specified,
which
causes the SQL30082 to be raised. Also, make sure that the user under
whose authority capture/apply is run is allowed to connect to both
databases.

Even i have seen in the replication center--Manage passwords and
connectivity--the userid and the password are same.
There is no non-existing user.Because each and every time i'm the only
person gettting connected.
I only created both the capture and apply databases.So,automatically
i'll be able to connect to both the databases.
Even then i'm not able to do.Please do suggest me.

sat wrote:
I have given the correct userid and password.Even now i was trying.But
its not working.

2006-09-20-13.20.51.019000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2836,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.21.51.175000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD960,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.CMD".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.22.51.300000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3292,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.23.51.597000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD2300,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Attached to" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

2006-09-20-13.24.37.879000 <cmdsEngineASN8008D "Capture" : "ASN" :
"Initial" : "Detached from" IPC queue with key(s)
"(OSSEIPC48tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC49tempDB2.SAMPLE.ASN.CAP.IPC.CMD3416,
OSSEIPC50tempDB2.SAMPLE.ASN.CAP.IPC.C".

This is wat i have seen in the capture log today .

Knut Stolze wrote:
sat wrote:

Actually for both the capture and apply programs the check status isin
resting.
So how can i activate them again?
So that the replication will work fine?Worker thread,Admin thread...
all these are the ones which i have seen in check status.
So, please guide me how i need to activate both the programs.
I'm sorry, but I don't see any point in continuing this discussion since you
don't appear to read my responses.

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Hi,

I think you have to forget to create a password file with asnpwd,
and than start the control server:

asnapply CONTROL_SERVER=xxx APPLY_QUAL=xxx APPLY_PATH="/db2/xxx/db2d
ump" PWDFILE=../../db2xx/replication/asnpwd.aut

Best regards,
Joachim Müller
Sep 22 '06 #16

This discussion thread is closed

Replies have been disabled for this discussion.