By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,282 Members | 1,615 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,282 IT Pros & Developers. It's quick & easy.

DISCOVER_COMM

P: n/a
Hi all,

Quick question, which strangly I just cannot find many results for.

Client, Solaris 10
Server, V4R5
App, IBM Universal DataBase

Problem: Trying to connect Client to Server DB2

I Think... I need to turn ON DISCOVER_COMM on the as/400.
I can't find a way to do this on the 400.
The IBM package cannot find any DB/2 servers on my network.

My network is pretty good, I can ping the 400 using port 446 using name
or IP
I use tn5250 to terminal into the 400, that works ok.

I have tried a using datastudio to connect, and have run into a
nightmare to do with the licence of db2jcc_license_cisuz.jar but have
run into a brick wall. I know that app is trying to work, because I can
hear the 400 grind it's disks like a good 'un.

So I decided to use the IBM package. BU]ut it just wont discover the
db2 server.

Any ideas how I can at least check if it on?

NOW for the weirdies.....

The AS400 is connected via a wireless bridge
(This is ok though I'm sure as it has no blocking of ports
capability and as a whole, it has never presented any problems before)

I can connect easly using iSeries Navigator and such tools from a PC, I
can see the database etc.

There is NO restrictions on the sun box or the gateway. And as such, I
have classed it as a red hearing. BUT!! I've been in IT for many years
now, and know not to completly dismiss something.

If I've not given enough info, then please say and I will try again.

So to recap, my main question is: How do I check if the setting
DISCOVER_COMM is ON on the AS/400?

Many thanks

Mark

Aug 11 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
DISCOVER_COMM is (I believe)unique to DB2 on LUW. You don't provide the
details in terms of what is on your client. If you want to access DB2 on
i-series from either a DB2 LUW client on Sun or from a DB2 LUW server on
Sun, you must use DB2 Connect ... and you must enable DB2 on the
i-series side for communications as a DRDA-AS (but you MUST have at
least a DB2 LUW client + DB2 Connect on the Sun machine). If you have
not done this, check your DB2 for i-series documentation (can't remember
which pub the details are in). You can also check the doc at

http://www-306.ibm.com/software/data...manualsv9.html

under "DB2 Connect".

Larry Edelstein
Hi all,

Quick question, which strangly I just cannot find many results for.

Client, Solaris 10
Server, V4R5
App, IBM Universal DataBase

Problem: Trying to connect Client to Server DB2

I Think... I need to turn ON DISCOVER_COMM on the as/400.
I can't find a way to do this on the 400.
The IBM package cannot find any DB/2 servers on my network.

My network is pretty good, I can ping the 400 using port 446 using name
or IP
I use tn5250 to terminal into the 400, that works ok.

I have tried a using datastudio to connect, and have run into a
nightmare to do with the licence of db2jcc_license_cisuz.jar but have
run into a brick wall. I know that app is trying to work, because I can
hear the 400 grind it's disks like a good 'un.

So I decided to use the IBM package. BU]ut it just wont discover the
db2 server.

Any ideas how I can at least check if it on?

NOW for the weirdies.....

The AS400 is connected via a wireless bridge
(This is ok though I'm sure as it has no blocking of ports
capability and as a whole, it has never presented any problems before)

I can connect easly using iSeries Navigator and such tools from a PC, I
can see the database etc.

There is NO restrictions on the sun box or the gateway. And as such, I
have classed it as a red hearing. BUT!! I've been in IT for many years
now, and know not to completly dismiss something.

If I've not given enough info, then please say and I will try again.

So to recap, my main question is: How do I check if the setting
DISCOVER_COMM is ON on the AS/400?

Many thanks

Mark
Aug 14 '06 #2

P: n/a
Thanks Larry, I haven't had time to check yet, but will do so tonight.

Mark

Aug 17 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.