470,619 Members | 1,493 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,619 developers. It's quick & easy.

Cognos Cube with DB2 "UOW Waiting" status

I'm try tuning a SELECT statement which is used by a Cognos cube on a
DB2 V7.2 +FP13. After I did the tuning, the "dynexpln" shows the
"total cost" is down to 8214567 from 37345265, also I try to run the
SQL in the cmd line, it now only took several minutes to return about
50M rows instead of +10 hours.

The cube is re-built after the tuning, and I could see the same SQL
running by "get snapshot for application.." , also the "list
application" shows that it is in "executing" status; after a short
while, the status changed to "UOW waiting" status. Sevral hours
passed, the SQL is still in "UOW waiting" status, and the "rows
read/fetched" from "get snapshot" is keeping growth continiously.

I'm confused, what does the "UOW waiting" really means, maybe just
waiting for the Cognos processing the data? Why the "rows
read/fetched" is growing?

Anyone can explain this? Thanks.

Jul 24 '06 #1
0 1542

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by John Yasaitis | last post: by
6 posts views Thread by Bart van Deenen | last post: by
reply views Thread by wxqun | last post: by
3 posts views Thread by =?ISO-8859-1?B?Rvpsdmlv?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.