By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,286 Members | 1,290 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,286 IT Pros & Developers. It's quick & easy.

DB2-Mystery with Multithreading and new compiler

P: n/a
Hi,

I have an unusual Problem with DB2.
It is DB2 Version 7 and Fixpack 13 under Windows.

We have written an application server which is accessing db2 via c++
and the cli interface.
We used IBM Visual Age as our compiler, because we had to support OS/2.

Now we ported it this year to windows and the microsoft-compiler (V8).
The access methods, the cli calls and so on didn't change.

Now the Problem:
The application server has to use multithreading to handle the client
requests. With the "old" server, everything is ok.
With the "new" server, on the same database, with the same settings,
multithreading doesn't work.
DB2 acts, as if the "MULTICONNECT" cli-property was not set. But the
db2cli.ini is default and the default value for MULTICONNECT is "1".
All funcion calls run without errors, I get different connection
handles.
But when I run a long SQL-statement for example, every other request is
blocked.
The CLI is waiting at the "SQLAllocHandle (SQL_HANDLE_STMT ..."
function.

I'm sitting here and I don't find any solution. It is exactly the same
system, the same database, the same CLI settings, the same accessing
source-code.

And the most confused is:
I tried DB2 Version 8.2 and there, everything is running right.
I hope I could make myself clear, if there are any questions, ask.

I hope there are any ideas here.

thanks,

Denis

May 10 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.