467,209 Members | 1,283 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,209 developers. It's quick & easy.

odbc connect string and library list

I am trying to write an app in vfp 8.0 using cursoradapters connecting
to an as400 db2 database. My goal is to set up a test data library
(called FRED) on the iseries identical to the production data library
and manipulate the library list the pc uses by changing the odbc
connection string. If my understanding is correct, the DBQ option of
the connection string adds libraries to the lib list, but I can't get
the cursor to load unless I qualify the table name with the library
name.

I also can not find any good documentation on IBM Access for Windows
ODBC properties but have found this one for LINUX(which is what I'm
going by).
http://www-03.ibm.com/servers/eserve...roperties.html

Thanks in advance.
Here's my code:

lcConnStr= "DRIVER={iSeries Access ODBC Driver};" ; +
"PKG=QGPL/DEFAULT(IBM),2,0,1,0,512;" ;
+ "LANGUAGEID=ENU;" ;
+ "DFTPKGLIB=QGPL;" ;
+ "XDYNAMIC=1;" ;
+ "DBQ=QGPL,FRED;" ;
+ "SYSTEM=SCCA400;" ;
+ "Trusted Connection=Yes;"

retval = SQLSTRINGCONNECT(lcConnStr)

<This doesn't work>
select PERCENT, NAME, ADDRESS1, TAXID, CHECKCODE, HOLDFUND, LLORDSWT,
REBATEAMT, ADDRESS2, CITY, STATE, ZIP, ZIPEXT, UPDSWT, CROPYR,
CONTRACT, SUB, IDNO from CPARTNERS

<This works>
select PERCENT, NAME, ADDRESS1, TAXID, CHECKCODE, HOLDFUND, LLORDSWT,
REBATEAMT, ADDRESS2, CITY, STATE, ZIP, ZIPEXT, UPDSWT, CROPYR,
CONTRACT, SUB, IDNO from FRED.CPARTNERS

Mar 23 '06 #1
  • viewed: 5170
Share:
2 Replies
In article <11*********************@g10g2000cwb.googlegroups. com>,
fr**********@yahoo.com says...
+ "DBQ=QGPL,FRED;" ;
+ "SYSTEM=SCCA400;" ;
+ "Trusted Connection=Yes;"


The docs say:
Note, the first library listed in this property will also be the default
library, which is used to resolve unqualified names in SQL statements.
To specify no default library, a comma should be entered before any
libraries.

So I guess you need to change the DBQ option to 'DBQ=FRED,QGPL;'
Mar 23 '06 #2
Thanks, that solved the problem.

Mar 24 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

12 posts views Thread by Remco Groot Beumer | last post: by
5 posts views Thread by Alec | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.