By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,610 Members | 1,697 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,610 IT Pros & Developers. It's quick & easy.

Data Replication DB2 VM to UDB with DPROP

P: n/a
Hello hello,

I am having a horrible time trying to set up some data replication
stuff.

source: DB2 Server for VSE/VM
target: DB2 UDB 7.2 on Windows

I am trying to do the definitions using Control Center and Data Joiner,
as well as a lot of hand-written stuff.

I just cannot get the nasty little blighter to work, and I have a
feeling that it won't, no matter how much I bang my (or its) head
against the wall.

I have tried to ask big Blue, but "The guy who is doing UDB and DROP
support is absent for weeks" is the response.

After creating all the definitions according to the (appallingly
written) instructions on the manual, I start the capture program on VM
and get the following:

================================================== ====================
TAKE SYNCHPOINT dont update REGISTER because commitseq was ZEROĽn in
setting n
seqrb 00000000094B00000AB8

not time to update CD_NEW_SYNCHPOINT

compared tmp_index 1 CD_NEW_SYNCHPOINT 00000000000000000000

with last CD_NEW_SYNCHPOINT 00000000000000000000

SYNCHPOINT not Updated at time be806096

TAKE SYNCHPOINT dont update REGISTER because commitseq was ZEROĽn in
setting n
seqrb 00000000094B00000AB8

not time to update CD_NEW_SYNCHPOINT

compared tmp_index 1 CD_NEW_SYNCHPOINT 00000000000000000000

with last CD_NEW_SYNCHPOINT 00000000000000000000

SYNCHPOINT not Updated at time be8060d2

TAKE SYNCHPOINT dont update REGISTER because commitseq was ZEROĽn in
setting n

================================================== ====================

puzzled? Join the club. I cannot even work out what nationality the
person who wrote those messages is...

I have progressed in my knowledge a wee bit - that is, I know that the
initial table load is being done (what is called a FULL REFRESH in
these places) but then the CAPTURE program does not record nor capture
any changes.

Have looked at the tables on both sides of the replication and the
thing that bugs me is that the SYNCHPOINT field is always null.

Also, I am obviously talking with IBM on a regular basis, and they
asked me to check if I had got a message in a table called
IBMSNAP_TRACE (on the VM side) where "message ASN0104 was recorded
(which means "The Capture program successfully processed a CAPSTART
signal. If this is the first CAPSTART signal associated with a
particular source table, this message indicates that the Capture
program is now capturing updates to the source table)" - needless to
say I have no such message.

other, random, messages that unnerve me are ones like "--* A SYNCHPOINT
value in the pruning control table at the source server has not been
translated by CAPTURE" that I get in DataJoiner when I try and force an
off-line load.
From my point of view, it is a matter of the stoopid initial load

programs that put the wrong values in the tables - but I really would
give quite a bit to know what values I can manually put where...

Any ideas or suggestions, again?

ciao!

Aurora Dell'Anno
DB2 Systems Engineer - DBA Team
tel.: +32 (0)2 739 7578
e-mail:
Au*********************@riziv.fgov.be
ad*****@bigfoot.com
_____________________________________________
No trees were killed in the sending of this message. However - a large
number of electrons were terribly inconvenienced.

Mar 17 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.