By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,514 Members | 1,717 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,514 IT Pros & Developers. It's quick & easy.

UDB sort sequence problem

P: n/a
Hi,
I created database using
CREATE DATABASE TEST ON D: USING CODESET 1250 TERRITORY HR COLLATE
USING
SYSTEM

in order to sort national specific characters in right order. But this
still doesn't work. Characters are inserted and displayed correctly,
but
the sort order is wrong.

I'm doing something wrong?

I'm using IBM UDB v7.2 on Windows.

Any help appreciated.

Filip

Mar 9 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Ian
I tested this on DB2 v7.2 and V8, and the sort order is definitely
wrong for one of Croatian letters. I fixed this with custom collation
but I think it should work correctly by default.

Mar 28 '06 #2

P: n/a
Ian wrote:
I tested this on DB2 v7.2 and V8, and the sort order is definitely
wrong for one of Croatian letters. I fixed this with custom collation
but I think it should work correctly by default.

Hi!

Yes, it is wrong. I'm from Slovenia and we have the same problem.
None of the Central Europe languages are correctly sorted :((( by default.
Let's hope that future DB2 versions will correct this.

Best regards,
Kovi
--
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
| Gregor Kovac | Gr**********@mikropis.si |
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| In A World Without Fences Who Needs Gates? |
| Experience Linux. |
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
Mar 29 '06 #3

P: n/a
Gregor KovaÄŤ wrote:
Ian wrote:
I tested this on DB2 v7.2 and V8, and the sort order is definitely
wrong for one of Croatian letters. I fixed this with custom collation
but I think it should work correctly by default.

Hi!

Yes, it is wrong. I'm from Slovenia and we have the same problem.
None of the Central Europe languages are correctly sorted :((( by default.
Let's hope that future DB2 versions will correct this.


Have you opened a PMR to get let the developers know about it?

--
Knut Stolze
DB2 Information Integration Development
IBM Germany
Apr 3 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.