By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,854 Members | 1,980 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,854 IT Pros & Developers. It's quick & easy.

Diag File Log Entry??

P: n/a
Does anyone have any idea what might be causing this error?
2005-11-02-11.23.02.769000-360 I17004595H370 LEVEL: Severe
PID : 3576 TID : 4632 PROC : db2syscs.exe
INSTANCE: DB2 NODE : 000 DB : CNTNTPUB
APPHDL : 0-434 APPID: *LOCAL.DB2.051102172303
FUNCTION: DB2 UDB, base sys utilities, sqleSubsequentConnect, probe:40
RETCODE : ZRC=0xFFFFFBF0=-1040

The platform is Windows 2003 Standard Server
Informational tokens are "DB2 v8.1.9.917", "OD_14086", "WR21350_14086",
and
FixPak "9".

Only about 40 concurrent users, database is very small, under 500 MB.

Thanks in advance!!!

Martin

Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
In article <11*********************@g47g2000cwa.googlegroups. com>,
mghale (ma*********@yahoo.com) says...
Does anyone have any idea what might be causing this error?
2005-11-02-11.23.02.769000-360 I17004595H370 LEVEL: Severe
PID : 3576 TID : 4632 PROC : db2syscs.exe
INSTANCE: DB2 NODE : 000 DB : CNTNTPUB
APPHDL : 0-434 APPID: *LOCAL.DB2.051102172303
FUNCTION: DB2 UDB, base sys utilities, sqleSubsequentConnect, probe:40
RETCODE : ZRC=0xFFFFFBF0=-1040

The platform is Windows 2003 Standard Server
Informational tokens are "DB2 v8.1.9.917", "OD_14086", "WR21350_14086",
and
FixPak "9".

Only about 40 concurrent users, database is very small, under 500 MB.

Thanks in advance!!!

Martin


The RETCODE=-1040 most likely means:

SQL1040N The maximum number of applications is already connected
to the database.

Explanation:

The number of applications connected to the database is equal to
the maximum value defined in the configuration file for the
database.

The command cannot be processed.

User Response:

Wait for other applications to disconnect from the database. If
more applications are required to run concurrently, increase the
value for maxappls . After all applications disconnect from the
database and the database is restarted, the new value takes
effect.

sqlcode : -1040

sqlstate : 57030
Nov 12 '05 #2

P: n/a
Thanks so much! That was exactly the problem. The app team
'supposedly' was using a connection pool on their end that was set to
20. So maxappls was set to 40. I increased it and all is working
great.

Thanks for the reply!!

Martin

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.