469,304 Members | 2,192 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,304 developers. It's quick & easy.

"User mapping missing" when accessing FEDERATED nickname

aj
DB2 WSE LUW 8.1 Fixpak 5
Red Hat AS 2.1

I'm trying to set up a federated view from one DB2 database to
another in the same instance on the same server.

I do a:
create server <SERVER> type DB2/UDB version 8.1 wrapper DRDA
authorization <INSTANCE_OWNER> password "<PASSWD>" options
(NODE 'LOCAL',DBNAME '<DBNAME>',FOLD_ID 'N',FOLD_PW 'N')

then I create a nickname against that remote db.

Everything goes fine, but when I try to access the nickname or
view in the CLP, I get:

SQL1822N Unexpected error code "User mapping missing" received
from data source "". Associated text and tokens are "".

My DBM cfg AUTHENTICATION setting is SERVER, and the 2 databases
are in the same instance, so I thought a user mapping was not
necessary.

The weird part is that, while logged in as the instance owner
in CC, I can right-click on the nickname, and successfully sample
the contents.

Any ideas?

aj
Nov 12 '05 #1
0 1634

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Tamir Khason | last post: by
1 post views Thread by fl | last post: by
1 post views Thread by contact.morrison | last post: by
reply views Thread by suresh191 | last post: by
1 post views Thread by Geralt96 | last post: by
reply views Thread by harlem98 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.