By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,018 Members | 901 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,018 IT Pros & Developers. It's quick & easy.

All linked DB2 tables viewable on 390, but only some are viewable after migration to AIX and v8

P: n/a
smd
Hello and thanks for taking the time to read this. I've looked all
over the web and newsgroups and can't find a solution to my problem.
Since the source of the data is DB2, I figured I'd give you guys a try
as well!

Back ground:
User at remote site has Access 2000 running on XP (don't know SP of
either). Linked tables are DB2 v8 running on AIX. All of the linked
tables are in the same database and schema.

Problem:
Some linked tables, when viewed in datasheet form from within Access,
display "#NAME?"; others do not. This problem started right afer the
database was migrated from 390 to AIX.

Things I've tried:
All obvious connectivity related trouble shooting (the server and DB
can be seen from IBM DB2 Configuration assistant and Putty, the DSN is
registered ODBC, etc.) Results: nothing out of the ordinary.

Reinstalled Msowfc.dll as suggested in KB article(not sure I spelled it

correctly here, but you get the picture) Results: no effect

Checked connection string using this command typed in the Immediate
Window: ?dbengine(0)(0).TableDefs("CAP_UFPWK_DPTMDSC_SLSST K").Connect
Results: Thought I had something here when one of the connection
strings was returned with the user's current ID, but an old password.
Had the user delete the linked table in Access (highlighting and
pressing delete key) and then set up the linked table again. Now all
connection strings are the same
(ODBC;DSN=LFPPROD;MODE=SHARE;DBALIAS=LFPPROD;). Unfortunately, no
effect.

I'm stuck! Anyone have similar problems? Anyone have a suggestion on
how to fix? Thanks in advance for your help!

Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.