By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,007 Members | 1,248 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,007 IT Pros & Developers. It's quick & easy.

DB2MSCS problem

P: n/a
Hi,

Running on Windows 2003 Advanced server I tried to configure
clustering with DB2 ESE (FP10) with the DB2MSCS utility. Defining the
cluster resources seems to be succesfull but the DB2 resource can't
be brought online.
The following message is displayed:
DB21516E DB2MSCS cannot bring resource "0" online. Ensure that the
properties of the resource are set correctly.

After that I configured the resources manual. Everything seems to be
fine but bringing the DB2 resource online just doesn't work and no
error message is displayed in the DB2DIAG log (with DIAGLEVEL 4).

I can start DB2 from the commandline or the services panel without a
problem, it's just the DB2 resource in the cluster definition that
fails.
The Cluster Administration Utility doesn't contain messages and the
event log only tells me that the resource could not be brought
online.

Does anybody know how to troubleshoot this?

TIA and kind regards, Gert
Nov 12 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
There is some dependancy of DB2 service to other resouce(HD, Network),
did you check they are online or not?
Or when you define the DB2 service, you give it the user name &
password, is it the right one?

Nov 12 '05 #2

P: n/a
In article <11**********************@g47g2000cwa.googlegroups .com>,
(sh*******@gmail.com) says...
There is some dependancy of DB2 service to other resouce(HD, Network),
did you check they are online or not?
Or when you define the DB2 service, you give it the user name &
password, is it the right one?


Yes, all resources were online. The right user is also defined. The
strange thing is that the db2diag.log doesn't ahow any message, the
clustering software doesn't seem to try to start the instance.
Nov 12 '05 #3

P: n/a
In article <MP************************@news.xs4all.nl>, ge**@invalid.nl
says...
Hi,

Running on Windows 2003 Advanced server I tried to configure
clustering with DB2 ESE (FP10) with the DB2MSCS utility. Defining the
cluster resources seems to be succesfull but the DB2 resource can't
be brought online.
The following message is displayed:
DB21516E DB2MSCS cannot bring resource "0" online. Ensure that the
properties of the resource are set correctly.

After that I configured the resources manual. Everything seems to be
fine but bringing the DB2 resource online just doesn't work and no
error message is displayed in the DB2DIAG log (with DIAGLEVEL 4).

I can start DB2 from the commandline or the services panel without a
problem, it's just the DB2 resource in the cluster definition that
fails.
The Cluster Administration Utility doesn't contain messages and the
event log only tells me that the resource could not be brought
online.

Does anybody know how to troubleshoot this?

TIA and kind regards, Gert

We found some additional information in the file
c:\Windows\Cluster\cluster.log

It shows that 'error 1060' is returned when bringing the DB2 resource
online. The windows 1060 error means that "The specified service does
not exist as an installed service.".

It looks like the DB2 resource is trying to start the wrong service
which means it's a DB2 bug.

Did anybody configure MSCS with DB2 ESE FP10 without a problem?

kind regards, Gert
Nov 12 '05 #4

P: n/a
Try to create another instance, bring it into MSCS.

Nov 12 '05 #5

P: n/a
In article <11**********************@z14g2000cwz.googlegroups .com>,
sh*******@gmail.com says...
Try to create another instance, bring it into MSCS.


Why? What dou you expect to see? What could be the cause of the problem?
Nov 12 '05 #6

P: n/a
If the new instance could be started in MSCS, then the problem is your
existing DB2 instance.
If not, I suggest you do a reinstall.

Nov 12 '05 #7

P: n/a
In article <11**********************@f14g2000cwb.googlegroups .com>,
(sh*******@gmail.com) says...
If the new instance could be started in MSCS, then the problem is your
existing DB2 instance.
If not, I suggest you do a reinstall.


As I said in my first post, I can start the instance without a
problem using db2start, net start and the service management window
so I doubt anything is wrong with the instance. Only the Cluster tool
can't start the instance.
I allready installed DB2 again but the problem still remains.
Nov 12 '05 #8

P: 2
I am not a db2 Admin but I have done couple times in production environment in my center. If you crate resource manually thats not your db2 instance. You have to go through db2mscs util. If you have two node cluster first stop db2 on second node and then try to run db2mscs on node1, thats delete your DB2 instance on node1 and move iot to Cluster. then try to fail over on node2 it should work. " if you get error when it moving instance to define cluster group try same from node2. stop db2 on node1 and run db2mscs on Node2. For me it worked great. If you have any more question send me email at anantminu@yahoo.com


In article <1128614324.016741.296970@f14g2000cwb.googlegroups .com>,
(shenanwei@gmail.com) says...[color=blue]
> If the new instance could be started in MSCS, then the problem is your
> existing DB2 instance.
> If not, I suggest you do a reinstall.
>[/color]

As I said in my first post, I can start the instance without a
problem using db2start, net start and the service management window
so I doubt anything is wrong with the instance. Only the Cluster tool
can't start the instance.
I allready installed DB2 again but the problem still remains.
May 3 '06 #9

This discussion thread is closed

Replies have been disabled for this discussion.